Rest API: + sign in termbase name

Hi,

I just found that if the termbase name contains a "+" character, then I cannot create new images in the termbase through the GS2017 REST API.

E.g. posting a request here : /multiterm/api/1.0/termbases/abc%2Bdef/multimedia results in HTTP404-not found, WITHOUT any response body.

If I simply use a nonexisting termbase name, but without + character in the name, then I also get http404, but the body is filled with the details, like

{
"errorCode": "TERMBASE_NOT_FOUND_EXCEPTION",
"message": "The searched termbase could not be found.\nAdditional info: XXXXXXXX."
}

 

As soon as I add %2B to the termbase name (existing or non-existing), the body is empty.

Is there a workaround for this maybe? (It is also an option to ask the clients not to use + in the termbase name, but maybe there is a better solution)

(e.g. GS: 14.2.32756.8 - SR1 CU8)

thanks,

Tamas

2 Replies Latest Replies: 5 Dec 2018 7:06 AM by Andrea-Melinda Ghisa

Related