How can I determine if the Rest API is activated for my installation?

When I run the request : https://myserver.com/documentation/api/index I get the main screen but not the lower section to Post. 

There is a mesage "Can't read from server. It may not have the appropriate access-control-origin settings." 

Support has deferred me back to this group for help.

Thanks,

Ron

Top Replies

Parents Reply
  •  Hi Michel,

    I finally got some help from and the workaround he suggested worked perfectly fine for us:

    It seems there was an update which broke the link.  You can fix it with this workaround.

     

    One time fix:

    -          On the GroupShare server edit “c:\Program Files(x86)\SDL\SDL Server\Web\swagger-ui\groupshare.json”:

    -          Replace “host”:”localhost:41234” with “host”:”servername” (without port)

     

    Then each time you want to use swagger:

     

    -          In your browser access http://<servername>/documentation/api/index (again no port)

    -          Replace http://<servername>:41234/docs/v2 in the top of the page by http://<servername>/swagger-ui/GroupShare.json (again no port)

    -          Click “Explore”

     

    You should now be able to use swagger interactively and you should not need any port open with the exception of port 80.

     Thanks!

Children