SDL Studio 2019 SR 2 - Sdl.Desktop.Platform.Services.IUserSettingsService service not available when creating FileBasedProject(projectInfo, templateReference) after updating to SR 2

Hi devs, hi community,

with an updated studio we run into the following issue.

  • Before the update we created a FileBasedProject with projectInfo and templateReference which worked as expected.
  • After the update the constructor keeps throwing the following exception: service not available Sdl.Desktop.Platform.Services.IUserSettingsService

We tried the following solutions:

  1. Restart after installing the update
  2. Reimport all references as suggested in
  3. Reset trados studio as suggested in

but couldn't fix the problem or figure out what the cause of the exception was.

Is it possible that a faulty Sdl.ProjectAutomation.Core.ProjectInfo causes the exception? Do we need to enter necessary values?

Do you have any other suggestions?

Best regards,


We updated from: Version

to: SDL Trados Studio 2019 SR2 Version