ConditionManagement10.CompareConditionCategories not working

I'm curious as to whether anyone out there has managed to get any output out of this ancient API call? I've gotten output out of every other call to this API, but the response object for this call always comes back with a return code of -1 and an empty payload. No exception is thrown.

I'm hoping this call works correctly as I'm not looking forward to rolling my own categories XML comparison algorithm :(

Many thanks for any help you can give.

Parents
  • Hi Colin,
    You might find something in the server-side logging near c:\InfoShare\Data\Logs\InfoshareAuthor_yyyyMMdd*.log that could help.

    What I'm more interested in, is your total use case when using this ConditionManagement10 API calls. Perhaps share code?

    Reason is that we are strongly considering to deprecate or even remove this old 1.0 API. To be clear we would not remove Condition Manager Client Tool functionality, but we would no longer offer a functional API replacement of ConditionManagement10

    Thanks for any feedback
    Dave
Reply
  • Hi Colin,
    You might find something in the server-side logging near c:\InfoShare\Data\Logs\InfoshareAuthor_yyyyMMdd*.log that could help.

    What I'm more interested in, is your total use case when using this ConditionManagement10 API calls. Perhaps share code?

    Reason is that we are strongly considering to deprecate or even remove this old 1.0 API. To be clear we would not remove Condition Manager Client Tool functionality, but we would no longer offer a functional API replacement of ConditionManagement10

    Thanks for any feedback
    Dave
Children