Under Community Review
over 1 year ago

Treat "space" and "ZWNJ" as the same character.

Hi,

We are your Iranian sales agent and I'm requesting this tweak on behalf of all Persian translators as we have received numerous questions and complaints about this. So in Persian, complex words are spelled either with a full space between the two (or more) parts or with a "zero width non-joiner". As it is, you have to save the several forms of a single word in SDL Multiterm for it to recognize different spellings of the same word. (Imagine doing that for every single word!) The standard and recommended format is the use of ZWNJ and I save my terms using that spelling. However, sometimes you receive documents where words are spelled with full spaces. In this scenario, you either have to manually edit the entire document first (out of the question) or add the non-standard spelling to your termbase as well. The second option, apart from being extremely time-consuming, difficult, and redundant, leads to two spellings being offered by Multiterm when translating into Persian. There seems to be no solution to this conundrum on the user's part. However, one simple solution you could implement would be to set the Multiterm to recognize Persian terms regardless of whether they are spelled with a ZWNJ or a space.

Thank you very much in advance