Under Community Review

Java Property files - Ability to disable the escaping mechanism or at least choose whether characters in a specific strings can be escaped or not


We have projects targeting Java Property files for a number of uses including reports. Some of these files contain code that should not be escaped.

For example, this source:

top_n.subtitle=Incidents logged in last <VALUE-OF>params["Logged_in_the_last_x_minutes"]</VALUE-OF> minutes
top_n_csg.subtitle=Incidents logged in last <VALUE-OF>params["Logged_in_the_last_x_minutes"]</VALUE-OF> minutes <BR>CSG: <VALUE-OF>params["CSG_filter"].displayText</VALUE-OF>
param.top_n.prompt_text=Top N
param_top_n.help_text=Enter the top N values to appear on the report

dashboard.html_format.major_category_within_sla.onload=[{"selector":":scope > body","index":0,"type":"attribute","name":"onresize","value":"dashboardFormatElement(\\"html\\", substituteDimensions(\\"{dashboard.html_format.default.resize}\\"));ret = redrawCharts(); if (ret) redrawCharts();"}]

Once translated, the output contains escape characters, specifically before double quotes and backslashes:

top_n.subtitle=Incidents protokolliert innerhalb der letzten <VALUE-OF>params[\"Logged_in_the_last_x_minutes\"]</VALUE-OF> Minuten
top_n_csg.subtitle=Incidents protokolliert innerhalb der letzten <VALUE-OF>params[\"Logged_in_the_last_x_minutes\"]</VALUE-OF> Minuten <BR>Mandant: <VALUE-OF>params[\"CSG_filter\"].displayText</VALUE-OF>
param.top_n.prompt_text=Top n
param_top_n.help_text=Geben Sie die Top n Werte für den Bericht an

dashboard.html_format.major_category_within_sla.onload=[{\"selector\":\":scope > body\",\"index\":0,\"type\":\"attribute\",\"name\":\"onresize\",\"value\":\"dashboardFormatElement(\\\"html\\\", substituteDimensions(\\\"{dashboard.html_format.default.resize}\\\"));ret = redrawCharts(); if (ret) redrawCharts();\"}]

I understand this is normal behaviour but in this instance there should not be any escape characters to preserve the functions. I have tried inserting the following line at the top

## Escaping=NoneInMessageFormat;

I also tried the "AllInMessageFormat" setting but this doesn't seem to have any effect whether I use Passolo 2015 or Passolo 2022 beta.

It would be nice to have the ability in Passolo to prevent characters in specific strings being escaped.


Max Cécilien