Using custom file types

Hello,

We are doing some testing of the TLT and encountered a problem with a custom XML file type. We've been successfully handling our customer's XML files for years in Trados Studio by using a custom file type we created. Now we imported that file type to TLT and did some testing there. The file conversion, processing, translation etc went fine, however the target file generated by TLT could not be imported back into our customer's system. Important to emphasize that there were no tag issues in the file.

Has anybody encountered this?

Thanks,

Csaba

Parents
  • Hi Csaba

    If you do not translate the file and just copy source to target and then try importing this into the customers system - do you still have issues?

    Also if you run the file through Studio and TLT - generate the target file and compare the output is there any noticeable difference?

    Can you attach the file so can look into this for you?

    Thanks
    Fas

  • Hi Fas,

    Sorry for the late reply, for some reason I was notified about your reply.

    I've run a comparison on the 2 target XML files (the one generated by Trados Studio - here referred to as First XML document and the one generated by TLT referred to as Second XML document).

     

    The only difference between the two is the way the date is handled under CreatedDate and ModifiedDate for each segment. In the one from Studio these dates are in the format 2019-04-27T13:06:10, whereas in the one from TLT it is 04/27/2019 13:06:10.

    There is no setting in either Studio or TLT for this as these are handled as non-translatable parser rules.

    Thanks,

    Csaba

  • HI

    What was the format in the original file?  Also can you attach the file\filetype so I can test on our side.

    Thanks
    Fas

  • Hi Fas,

    The original format was 2019-04-27T13:06:10. This was also investigated by support and it does seem to be a bug that needs to be fixed. Nevertheless, I could send you the files if you provide me an e-mail address where I can send them to.

    Thanks,

    Csaba

Reply Children
No Data