(More) Job Tools not running external shell script

Good morning,

 

I might be setting myself up for huge embarrassment but I am at my wits end.   I'm modifying a legacy inherited korn shell script that executes at the job level (/procs/jsc).  For some reason it just will not run.  I've tried restarting the XPP service, opening up all permissions, the gamut and it just WILL NOT execute : )  

 

To debug, I created a test script (for brevity's sake I've not included all iterations)...

 

#!/bin/bash

echo "0:$0"   > /tmp/mylog;
echo "1:$1" >> /tmp/mylog;
echo "2:$2" >> /tmp/mylog;


exit;

... to see if XPP is even passing something valuable and I get no output.  I've run this from the command line to make sure it writes to the log and all is fine.  I tried ksh, and bash.   I've tried it with and without . /var/www/xpp/xz/etcxyvision/xyv.shpaths, and a whole bunch of variations in between, nothing works.

 

Can anyone help me understand how XPP executes external commands like this and what is the best way to debug problems?  There must be something I'm missing.  Any help would be appreciated.

 

Thanks - Tod

 

Just to add, I'm executing from XPPathfinder, right click on job tool, more tools, and selecting the script from the list.  The 'same' program in Perl works!

Parents Reply Children
No Data