Unable to download from SDL AppStore

Hello colleagues


I can enter the AppStore and find the app I want to download without problems. When I click Download I am asked to log in, and so I do. However, the AppStore asks me again to log in, and I am caught in a loop.

I only have ONE SDL account.

I have tried the following. To log in to my account before going to the AppStore, to go to the AppStore and log in when asked by the AppStore, to clean my browser's cache before going to the AppStore, and to update my browser - Google Chrome - before going to the AppStore. Always the same problem: I am asked to log in in order to download an app from the Store.

Can anyone help?


1 Replies Latest Replies: 16 Mar 2019 6:02 PM by Willem Dubelaar
  • In the past, I have had a similar problem with my default browser, Firefox. Through trial and error, I found that using a different browser (Edge) solved the problem. Nowadays, with cookies enabled, it works well (in Firefox), even logs in automatically. You might try a similar thing.