How does Integrated Segment Actions compare to SDLToolkit?

Dear Studio 2017 users,

Does anyone use Integrated Segment Actions?  It looks like SDLToolkit and I wonder if there are additional benefits to learn and use ISA since I already have SDLToolkit in place.

I also want to mention that the download link was broken for ISA when I tried it earlier.  

Thank you.



10 Replies Latest Replies: 24 Mar 2017 10:46 PM by Paul Filkin < 1   2  >
  • Hi Chunyi,

    Not sure what the problem was with the download but it seems to be working fine now.

    On the differences between toolkit and ISA... here's a short and incomplete list:

    - In ISA no need to add your files, works on the active project/file
    - In ISA no ability to perform actions across projects
    - Toolkit has a much more powerful set of search & replace features
    - Toolkit can split files
    - Toolkit uses boolean logic to select segments with specific TM match values so potentially more powerful
    - ISA makes selecting segments with specific TM match values a piece of cake!

    Then there are a few small differences here and there. I think the intention of the ISA plugin was to make it easier and more integrated to do the most common functions in the toolkit. Horses for courses I think!


  • In reply to Paul Filkin:

     Hi Paul,

    This app sounds interesting and I would love to try it.  However, the link is still broken.  I am attaching the page that shows the error after I click on the Download link.  

    I will definitely try it again when the link is fixed.  Thank you for the comparison!!



  • In reply to Chunyi Chen:

    Maybe you need to clear your browser cache after the problems we had a few weeks ago? Try pressing Ctrl+F5 when you go to the app page.
  • In reply to Paul Filkin:

    I tried and am still getting the same message. I do not have problems with other apps.

  • In reply to Chunyi Chen:

    Hi Chunyi,

    Fortunately I managed to reproduce this myself just now. So I removed the app and republished it which fixed it for me. Please can you test again now and see if things work for you now. Make sure you Ctrl+F5 first in case you are caching the old one.


< 1   2  >