SDLTM Repair error message

I believe I have a corrupt TM file so tried to run SDLTM Repair. As soon as I select my TM and press Integrity Check I get this error:

Unhandled exception has occurred...

Could not find the file 'C:\Users....\log_20a52687....txt"

Any idea why this app gets this error? 



10 Replies Latest Replies: 15 Jun 2016 3:02 PM by Paul Filkin < 1   2  >
  • Hi Glen,

    It may be that the app was not installed as admin.


  • In reply to Paul Filkin:

    Thanks Paul. I right clicked on both the install program and the app itself and chose Run as Administrator. That didn't help. I also confirmed that I had the right .Net version and even moved a copy of the TM into the same folder as the app. Same error.
  • I have the same problem. The log I see after the ap crashes is this (in case it helps someone propose a solution):
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.IO.FileNotFoundException: Could not find file 'D:\...\log_eedd2618-7ad0-4fe1-a9f3-68a89a736d58.txt'.
    File name: 'D:\...\log_eedd2618-7ad0-4fe1-a9f3-68a89a736d58.txt'
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean checkHost)
    at System.IO.StreamReader..ctor(String path)
    at Sdl.Community.TMRepair.SDLTMRepair.btnIntegrityCheck_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 4.6.1080.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Program%20Files%20(x86)/SDL/SDL%20Community/SDL%20TMRepair/Sdl.Community.TMRepair.exe
    Assembly Version:
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    Assembly Version:
    Win32 Version: 4.6.1081.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    Assembly Version:
    Win32 Version: 4.6.1078.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the section.
    The application must also be compiled with debugging

    For example:

    < jitDebugging="true" />

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

    No solutions as of yet, but I am still trying to figure this out.

  • In reply to Popie Matsouka:

    I'm facing the same issue. Any progress on this?

    Also, if I try to install the plugin in Trados, nothing really happens.


    I'm using the latest Version of Trados 2017 on Windows 10.

  • In reply to Remy Blaettler:

    Hi ,

    It should install into Add-Ins. If you don't have this have you tried manually copying the plugin into the roaming plugins folder?


< 1   2  >