Exclude strings in a .txt file

Hello,

 

we are currently having problems, excluding strings in a .txt file when we create a new project.

The file looks like this:

   Stellgeraet[3].Bezeichnung_Abs := '2:SG:3';
   Stellgeraet[3].Bezeichnung_Sym := 'Vereinzelung Radschraube 1';
   Stellgeraet[3].Bewegung_links_Abs := 'A100.1';
   Stellgeraet[3].Bewegung_links_Sym := 'zurück';
   Stellgeraet[3].Endlage_links_Abs := 'E4.3';
   Stellgeraet[4].Bezeichnung_Abs := '2:SG:4';
   Stellgeraet[4].Bezeichnung_Sym := 'Blasluftschuß Radschraube 1';
   Stellgeraet[4].Bewegung_links_Abs := 'N A100.5';
   Stellgeraet[4].Bewegung_links_Sym := 'aus';

 

We only need to translate the yellow text. How do we have to set the project settings, to only get this marked text?

We tried it with Document structure to define the start and the end of the text that needs to be translated with :=' for start and '; for end (but it didn't work).

We also tried to set inline tags, which also didn't work.

 

We appreciate every kind of help.

 

If you have further questions, please ask.

 

Best regards,

Marius Dieterle

9 Replies Latest Replies: 27 Jun 2017 5:39 PM by Paul Filkin < 1   2  >
  • In reply to Claudio Nasso:

    Dear Claudio,

    I am so happy to find this answer too.

    But I also have a similar problem. I have a tab delimited (.txt) document and the text is separated by tab, not by (') and (') as the example above. How to process it? Example:

    40    350    1    <korean characters>    This text should be translated1    <another character>

    41    351    1    <korean characters>    This text should be translated2    <another character>

    42    352    1    <korean characters>    This text should be translated3    <another character>

     

    How to translate the yellow parts only? What "character" to be used as the opening and closing pattern? The file was OK on Excel, and I wish it is an Excel file or <.csv> file. But unfortunately, the text is in <.txt> format.

    Thank you.

     

    Sarah

  • In reply to Sarah -:

    Hi  

    Perhaps the easiest solution is to just import the txt into excel then just hide the columns you don't want? If it's tab delimited as you suggest then they should nicely split like this:

    Save the file as excel and then just hide columns A, B, C, D and F.  When you're done translating just save the target file, open in Excel and save as a TXT again.

    Regards

    Paul

  • In reply to Paul Filkin:

    Hi Paul, thank you for the solution.
    I have just tried to do that. But when I save as the excel file back to txt and open in Notepad++, the Korean characters do not appear properly. They appear as ???? characters instead. Any further solution? Many thanks.

    Sarah
  • In reply to Sarah -:

    Hi ,

    Make sure you use the option to save as "Unicode Text (*.txt)" and then it should be fine. CSV is a problem but Excel can manage to save as unicode in the txt format.
< 1   2  >
Related