An error occured whilst trying to determine the file version

A week ago I started to have a problem when reopening projects. After I open Trados, I see that the project has disappeared from the project pane and when I come to reopen it by browsing to the right file, Sdl Trados 2017 comes up with the message "An error occurs whilst trying to determine the right version". I have tried deleting the default Trados template file as recommended in previous community posts but that doesn't seem to work.. The only workaround I have found up until now is to recreate the project, but then I lose most  of my recent edits to the translation file as the TM has not been updated properly. I would appreciate any help as I have lost a lot of time due to this error.

2 Replies Latest Replies: 5 Aug 2018 3:49 PM by Paul
  • Hi

    This may be a problem to resolve with your antivirus. Try working through this article:
  • I've experienced the very same problem with Studio 2019. Recreating the project, closing Trados Studio 2019 and then reopening the app results in the very same issue: namely, the project is once again deleted from the project list. I had a look at the projects.xml file in Documents\Studio 2019. The project was completely missing from the list, even though it still existed on my hard drive.

    As a test, I tried moving the entire project folder to a different directory with a shorter file path, and then used "Open Project" to reopen the project in Studio 2019. This time, I was able to successfully reload the project. After closing and restarting the app, the project was still there in the list.

    Based on this, I would surmise that Studio 2019 has difficulties with long file paths. (I am using Studio 2019 in a Parallels Desktop virtual machine on a Mac, so the network path referenced is a little longer than it would have been if created in a Windows-only environment.) You might like to try moving the project folder completely to the Documents\Studio 2019 folder and try to re-add the project.

    I've also noticed that Studio 2017/2019 has troubles with files that contain certain special characters. In one case, I had a project that contained a single double-byte character at the end of the project folder's file name. Deleting that single character solved the problem, and Studio 2019 happily opened the project and added it to the list. 

    I would also like to report this issue to SDL for their action...