Cannot export target file from Excel

Not sure why this is happening in the first place. It seems somehow SDL Trados Studio remembers the original path of the file at the translator's end. I got a translated SDLXLIFF file from a translator. I made some changes to translation. Now, I am trying to save the file, but I initially got this message:


"file xxx doesn't exist" and it gives me the path from translator's machine which is "C:\ZZ\WORK\Work from home\2018\December\30-12".

So, I tried to go along with Trados and I created the same exact path on my machine. Now, when I try to export target or save it as target, I get this error message:


"Failed to save target content: The paragraph unit supplied should always have Contexts properties defined!"

Not sure what does this mean? Any idea? 

How I can resolve this issue? Also, is there any logical explanation of such issue in the first place?

I am using SDL Trados Studio 2019 by the way.



14 Replies Latest Replies: 1 Jan 2019 12:04 PM by Evzen Polenka < 1   2   3  >
  • In reply to Mohamed Zeid:

    Mohamed Zeid
    2) It was translated by a translator using SDl Trados Studio 2015

    The point is to know every little details of this step - every little click and operation the translator did here.

    Mohamed Zeid
    6) I created the same path on my machine trying to trick SDL Trados Studio

    When you say "path", do you mean only the path (i.e. folder), or did you also put any file in there (with exactly the same filename which Studio complains that it's missing)?
    It's necessary to put the original untranslated source file there, but with exactly the same filename which Studio wants to be there.

    Mohamed Zeid
    I also found out that the segmentation was different this time. Some of the bigger paragraphs were segmented in sub-segments, so Perfect Match or CM match was not auto-populated from the TM. Not sure if the translator used a different segmentation, but I really doubt it.

    And I truly believe the opposite - that the translator DID use god-knows-which weird process (i.e. also segmentation)...
    That would not be suprising when the resulting SDLXLIFF file was so "corrupted"...

    Mohamed Zeid
    Here is also the stack trace, it could help.

    The error message is weird. It would suggest that you have put some incorrect file in the created path.

  • In reply to Paul:

    I'm wondering if this could be the scenario:
    - translator opens the SDLXLIFF in editor
    - this makes Studio to extract the embedded source file to temporary external file and replace the embedded content with reference to external file
    - translator does not properly save the file (or close the editor) and copies the "draft" SDLXLIFF from the project structure and sends it out
    This is IMO a theoretical way to get the SDLXLIFF with reference to external temp file instead of file properly embedded inside the SDLXLIFF. Still, it depends if my assumption about Studio creating the temp file and referring to the temp file (the second step) is correct - this should be confirmed/denied by SDL staff.
  • Hi ,

    I have run some tests in trying to reproduce the issue that you have mentioned here.  To avoid any misinterpretation, can you please confirm the steps that I have mentioned underneath.

    1. Create a new project in 2019 SR1
    2. Add a single xlsx file.
    Q 1: Is the *.xlsx file embedded in the SDLXLIFF file?
    3. Complete the project creation.
    4. Created a Studio Package and provided it to the linguist.
    Q 2: Did you provide the linguist with SDL Studio Package, target SDLXLIFF file and or the original source file (*.xlsx), or simply the entire project?
    5. Your understanding is that the Translator opened the studio package, translated the file and provided you with the translated file.
    Q 3: Is there a reason why the linguist did not provide a return package?
    Q 4: Any additional pre-processing done by the linguist?

    Tip: you can configure whether the native file is embedded in the SDLXLIFF file by updating the setting mentioned here

    Given the information you provided, I have deducted that your case is best aligned with the following scenario; if different, please advise.


    •    Created a project in Studio 2019 SR1 with a single *.xlsx file
    •    *.xlsx embedded in the SDLXLIFF file
    •    Created a SDL Studio Package
    •    Opened the package and translated the file
    •    The linguist did not create a return package; instead sent the translated SDLXLIFF file
    •    Copied the translated SDLXLIFF file back into target folder of your project, overwriting the existing file.

    In this scenario, the only case where I can see it being reproducible is when the translated SDLXLIFF file that you receive from the translator is recreated from the native file.  The original path of the reference file is defined when the file is created and relevant when not working with an embedded native file. 

    From the tests that I carried out, the original path was not updated when simply providing translations in the SDLXLIFF file. However, I was successful in updating this original path information, when creating a new project from the native file, as follows:
    •    Open the studio package
    •    Open the file in the editor and select the option File>Save Target As
    •    Create a new project from the native file.

    Note: In this user-case, it can also be seen that additional complications may occur; including variant segmentation & whether or not the native file is embedded with the creation of the new project, which might lend itself to the issues noted by .

    Tip: You can verify if the base64 encoded string of the embedded file is validate from here: Simply create a separate file with only the base64 encoded string and upload it, under the section: ‘Decode file from Base64 format’.

  • In reply to Evzen Polenka:


    1) It would be difficult to know every single click the translator did. I checked with the translator and all what she did was opening the file in SDL Trados Studio and translate it. She didn't even create a project.

    2) What I mean by 'path' is this: When I finished reviewing the file, I tried to save the target file, but for some reason, SDL Trados Studion complained about a path that was actually the path from translator's machine. So, I tried to mimic the same exact path on my C Drive trying to trick Trados Studion that the file is basically opened on the same machine, but this didn't resolve the issue. I hope this answers your question.

    3) That was the error message. It's weird, but what is weirder is actually this Trados Studio error, especially the one regarding the translator's path that still remembers it for some reason.
  • In reply to Patrick Andrew Hartnett:

    Hi ,

    I checked with the translator. She simply opened the XLSX file in Trados Studio and she didn't create a project for it. I didn't create a project at my end as well because it was a small file.

    I hope this helps answer some of your questions.

< 1   2   3  >