Pre-translate freezing, taking forever to cancel, taking a long time to save, stalling on "searching" TM hits, eating CPU


Lately pre-translate has been taking forever. Sometimes over an hour for processes that used to take just a few minutes. If it's not slow, then it simply freezes. 

This small project using a local TM and MT (I remove the MT it's still slow with the local TMs) decided to freeze at 68%. It stayed there for 20 minutes and then I gave up and canceled. Then instead of immediately canceling, it just said "canceling" for 10 or 15 minutes. 

During this time, I tried just forcing trados to close down. This what my task manager looked like. 

I tried individually closing down the batch processing window and SDL Trados window but it didn't close. Instead, I got another error telling me to first close the batch processing window with the "cancel" button. But as you can see above, all buttons were greyed out on the patch processing window. 

After about 10 minutes I was able to close it all down but this was so frustrating not even being able to forcibly close down Trados.

Why is this happening?

I use the latest version of Studio 2017. And have a fairly beefy, new computer that was bought to specifically to handle Trados.

So, then I just went to translate normally without doing a pre-translate and Trados wouldn't return TM or MT hits. It would just say "searching" and never finish.

Simply saving the xliff takes a minute. After clicking Batch Task, it takes a minute for the drop down screen to return.

While it was "saving" my CPU usage of Trados peaked around 93%. 


I referred to this similar sounding post:

I tried turning of fragment matching for both editor and batch tasks. Didn't work. Froze at 69% and is still currently "canceling".

This time it's a 4-page word document in Japanese, similar to the linked post. On Monday I'll try copying the text to a txt file and see if that works.

Any other suggestions though?

6 Replies Latest Replies: 7 Dec 2018 10:14 AM by Steven Whale < 1   2  >
  • Hello ,

    This nay again be stating the obvious, but please check that Studio is added to the white list.
    I would then maybe suggest creating a new project (with a new template) with just the file and local TM.
    Does this work as expected?
    If so, add in the external MT providers one by one and we should be able to narrow down where the issues are arising.
  • In reply to Steven Whale:


    Please check that Studio is added to the white list.
    ---Forgive me but I do not know what this means. If there is any sort of "white list", I have never touched or added anything to it... where ever it is.

    I would then maybe suggest creating a new project (with a new template) with just the file and local TM.
    --That did it. There's something wrong with the settings in my "Keenan" project template, but the "default" template works. Using the default project template plus any and every combination of my TMs and MT providers finishes the pre-translate within 2 minutes. Whereas my "Keenan" template processing with any one TM or MT on their own and always freezes and crashes. So I guess, somehow, the problem has to be in the project settings of my project template.

    I can do what I set out but I can't see why my project template caused a problem. I had even turned off fragment matching/repair for batch tasks and editor. 

    If I sent you my default template and my Keenan template plus a TM and a file, would that help get to the bottom of this? I'm really curious how a template causes this so that I can tell my other team members what do (or what not to do) when this happens.

  • In reply to Keenan Cooper:

    Hello ,

    Sorry for not being clear.
    When I meant add to 'white list' I meant add Studio to your AntiVirus provider- maybe worth checking with your IT department about this.

    However, as you say the default template works ok, its only your 'Keenan' template- then obviously we should investigate this.
    Please send me the two templates/TM/file/TB and a short explanation of your processes etc. to and I will be more than happy to have a look at this for you.
  • In reply to Steven Whale:

    Thank you, I'll prepare an email shortly.
  • In reply to Steven Whale:

    Did you get my e-mail? It was sent December 12th.I also e-mailed you January 11th with a similiar problem a coworker was having.
< 1   2  >