crash at spellchecking problem persists even after Trados 2019 Feb 7 SR1 update

Hello,

I have been having this problem since 2009 version. But it is sporadic. Sometimes with XML sometimes with Word documents, when I spellcheck after completing the translation, Trados crashes.

With some files, like the current one, 1009-word Word document. No strings in the text except square brackets [br] . It crashes at Segment 8 or 9 which is a plain text. It could be duration of use. Not sure.

With the larger file, I keep saving every few minutes after making corrections and jot down the segment number when it crashes. I continue from where I left after starting Trados again.

I tried turning off antivirus and firewall. Didn't work. Fresh restarted PC. Did not work. I have this problem in both Windows 7 and Windows 8. Trados 2019. I had recently reset Trados settings.

No specific error message. Just Close Program and Debug buttons available.

Yesterday, upon seeing the notification, I have upgraded to Feb 7 version. No improvement on this. And, worse, Trados can't find that file, though it is there physically. Below is the error message. I can't open the file at all.

Thought and wished this spellcheck issue would have been solved long time ago.

Any ideas

Thank you

Best regards

Hakan

 

 

 

<SDLErrorDetails time="10/02/2019 08:20:12">
  <ErrorMessage>The file at location 'F:\trados2019\projects\enigmasoftware\tr-TR\20190204 enigma cy\20190204 cy cross sell.docx.sdlxliff' does not exist!</ErrorMessage>
  <Exception>
    <Type>System.Exception, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</Type>
    <HelpLink />
    <Source>Sdl.FileTypeSupport.Framework.Implementation</Source>
    <HResult>-2146233088</HResult>
    <StackTrace><![CDATA[   at Sdl.FileTypeSupport.Framework.Integration.FilterManager.BuildExtractor(String filePath, CultureInfo suggestedSourceLanguage, Codepage suggestedCodepage, INativeTextLocationMessageReporter messageReporter)
   at Sdl.FileTypeSupport.Framework.Integration.FilterManager.AddExtractorsForConverter(IMultiFileConverter converter, String[] nativeFilePaths, CultureInfo suggestedSourceLanguage, Codepage suggestedCodepage, EventHandler`1 messageHandler)
   at Sdl.FileTypeSupport.Framework.Integration.FilterManager.GetConverter(String[] nativeFilePaths, CultureInfo sourceLanguage, Codepage suggestedCodepage, EventHandler`1 messageHandler)
   at Sdl.FileTypeSupport.Framework.Integration.FilterManager.GetConverterToBilingual(String[] nativeFilePaths, IBilingualDocumentGenerator writer, BilingualDocumentOutputPropertiesProvider outputSettingsProvider, CultureInfo sourceLanguage, Codepage suggestedCodepage, EventHandler`1 messageHandler)
   at Sdl.TranslationStudio.Editor.TranslationEditor.TranslatableDocument.Load(IJobExecutionContext context)
   at Sdl.Desktop.Platform.Services.JobRequest.Execute(IJobExecutionContext context)
   at Sdl.Desktop.Platform.Implementation.Services.Job.<_worker_DoWork>b__47_0()
   at Sdl.Desktop.Logger.Log.Resources(Object message, Action action)
   at Sdl.Desktop.Platform.Implementation.Services.Job._worker_DoWork(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)]]></StackTrace>
  </Exception>
  <Environment>
    <ProductName>SDL Trados Studio</ProductName>
    <ProductVersion>15.0.0.0</ProductVersion>
    <EntryAssemblyFileVersion>15.1.2.48878</EntryAssemblyFileVersion>
    <OperatingSystem>Microsoft Windows 8.1</OperatingSystem>
    <ServicePack>NULL</ServicePack>
    <OperatingSystemLanguage>2057</OperatingSystemLanguage>
    <CodePage>1252</CodePage>
    <LoggedOnUser>USKUDAR\HAKAN</LoggedOnUser>
    <DotNetFrameWork>4.0.30319.42000</DotNetFrameWork>
    <ComputerName>USKUDAR</ComputerName>
    <ConnectedToNetwork>True</ConnectedToNetwork>
    <PhysicalMemory>4066584 MB</PhysicalMemory>
  </Environment>
</SDLErrorDetails>

3 Replies Latest Replies: 18 Feb 2019 1:48 PM by Steven Whale
  • Hello  ,

    The problem here I suspect, is that you have you file stored on the 'cloud F:\ drive' and there is something blocking the smooth connection (especially as you say this has been happening since 2009!)

    The first test here I would do, is download the file to your local machine - rename the file and save.
    Now create a new project with the file and work as normal with local resources.-
    If as I suspect there are no further issues- then you will need to look closer at the cloud drive where you are storing the file and ensure you have 'whitelisted' Studio/MultiTerm properly.

    Please let me know how you get on.

  • In reply to Steven Whale:

    Hello,

    Thank you for your reply.

    Sorry that the drive letter was misleading. It is D or F by standard installation. When I started using my laptop, I needed to make the letter F. So it is a logical drive.

    Someone from SDL technical team will contact and check.

    I could not replicate the error because it is giving the error message.

    Also because spellcheck is complete, it does not perform spellcheck any more even if I drag and drop a renamed version of the file.

    Let's see if they can find out what it is.

    Thank you
  • In reply to Steven Whale:

    Hi Steven,

    Someone from SDL contacted me yesterday.

    Unfortunately, there wasn't much he could do.

    I thought Trados would have the facility of keeping the logs for later debugging purposes. Because the issue was sporadic and I could not find the reason, he could not see.

    He noticed that I moved from Hunspell to MS Word spellchecking, but it has only been a couple of days. Apparently, Hunspell had some erroneous spelling which almost cost me the project (still waiting for the result), therefore I shifted to MS Word dictionary. But crashing during spellchecking has been there for some time.

    Only way would be like I would keep my computer open when that crash happens, log a case and wait to be remotely connected. Even then, there is no "save error log" function like in other situations.

    As for the above error message, after Trados crashed during the spellchecking, it somehow renamed the file by appending some numbers at the end of the file. Therefore Trados could not locate the file. Renaming it back to original solved the file related problem. But not crashing during spellchecking.

    Bit disappointed.

    Thank you for your concern
    Best

    Hakan

Related