Adding a new default language after having already installed SDL Trados Studio 2017 SR1

Hello Paul,

I would like to ask you which procedure should I follow if I want to add a default language to my SDL Trados Studio 2017.

When I installed it I forgot to set all 5 default languages and now I would like to add the French language, but how can I do it?
I was told to uninstall and re-install the software againg with the hope to get the wizard asking me for the addition of the default languages, but unfortunately this did not happen. After reinstalling it I got exactly to the same position where I was before uninstalling it.

How can I force the installation procedure prompting for the addition of the 5 default languages?

I thank you in advance for your appreciated response.

Regards,

Paolo

1 Replies Latest Replies: 16 Mar 2019 3:32 PM by Alison Field
  • Hi 

    If reinstalling or resetting Studio hasn't worked for you, it is possible to reset the default languages entry in the computer Registry to do this. You can either do it yourself, or contact installation help to ask them to do it...

    If you feel confident about editing the registry, here are instructions. Follow them precisely as editing the registry is a risky business...

    Editing the registry key to remove 5 languages from Studio Freelance version

    Close all SDL products.

    In your 'Type here to search' window at bottom right of your screen, type 'regedit'.

    Open the Registry Editor.

    Either search manually:

    The actual address is HKEY_CURRENT_USER\Software\Microsoft\LDSRClient5

    Or click on 'Edit > Find' or use Ctrl+F 

     

    In the box that appears, type 'LDSRClient5' for Studio 2017 (it would be LDSRClient15 for Studio 2019 or 1,2,3or4 for earlier versions) then hit 'Find'

    The search will take a while as the registry is very large and complex:

     

    When the registry key appears, right-click on it and select 'rename'. 

    Add 'old' to the end of the LDSRClient5 name.

    Close the registry.

    Open Studio and you should find that it prompts you to add your 5 languages again. Note that you don't need to add more than one variant of any language as all other variants of that language will work once it has been added.

    Only do this if you feel confident enough to change your PC registry. If not, contact installation support here:

    Installation support

    Fill out the form, explain your problem, quote this post, and give them an accurate email address to contact you on and they can access your computer to change that setting for you.

    All the best,

    Alison


Related