Error message: Object reference not set to an instance of an object

Hi,

I am getting an error message (Object reference not set to an instance of an object) when trying to generate a target translation in Studio 2014. 

I have already tried some of the solutions mentioned in the forum but none worked... 

Any ideas?

Here is what I have tried already…..

If Studio starts, but shows the error message Object reference not set to an instance of an object when you switch between different dialogs and views:

    1. Open Studio.
    2. Activate the view where the error occurs (for example the Editor view).
    3. Click View > Reset Window Layout.
    4. Click OK to confirm resetting the window layout.

      If the error message still appears after following the steps above, follow the instructions under Solution 2 below.

       

      Solution 2

        1. Rename the setting files and run a repair installation

          1. Close all SDL applications.

          2. Go to the following folder: 
            • SDL Trados Studio 2011
              • Windows XPC:\Documents and Settings\[USER_NAME]\Application Data\SDL\SDL Trados Studio\10.0.0.0
              • Windows Vista/7/8C:\Users\[USER_NAME]\AppData\Roaming\SDL\SDL Trados Studio\10.0.0.0
            • SDL Trados Studio 2014
              • Windows XPC:\Documents and Settings\[USER_NAME]\Application Data\SDL\SDL Trados Studio\11.0.0.0
              • Windows Vista/7/8C:\Users\[USER_NAME]\AppData\Roaming\SDL\SDL Trados Studio\11.0.0.0

          3. Rename the following XML files (for example, add an underscore before/after the filename):
            • BaseSettings.xml
            • Plugincache.xml
            • UserSettings.xml

          NOTE: If you do not find this folder, make sure that these files are not hidden. See KB article #3330: Show hidden files and folders on Windows operating systems.

       

      1. Run a repair installation

        1. Open the Control Panel:
          • Windows Vista/7Start > Control Panel > Programs > Programs and Features.
          • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.

        2. Click to highlight the damaged SDL Trados Studio version and click Repair.

        3. Restart Studio.

      3 Replies Latest Replies: 22 Jun 2015 7:28 PM by Walter Blaser
      • Clothilde

        This may be caused by the document itself and not necessarily by the software. Did you run a Verify (F8) on this document to make sure that the translation does not contain any tag errors?
        What happens when you try to do a preview, do you get the same error?
        Try to open the source file and do a preview without translating any of the segments (make sure that the right-hand column is empty or run the batch task "Pseudo-Translate).
        If this preview also fails, then this means that the document is incompatible with Studio and needs to be modified (source). If this preview works fine, it means that the error has been introduced with your translation and you need to verify that you don't have any tag errors.
        Should the document be incompatible with Studio (case 1), report again and we'll arrange to have a look at your document.
        Walter

      • In reply to Walter Blaser:

        Walter,

        I seem to be encountering the same or a very similar behavior in Studio 2015. There is a slight difference, though. I encounter the error once I have indicated a single file for translation, as soon as I click on the batch tasks icon. I have already followed all of the above steps and haven't started to translate the file, yet. A preview works fine, though. But not being able to pre-translate the file or perform any of the other batch tasks is a problem.

        A penny for your thoughts,
        Roland

      • In reply to Roland Grefer:

        Hi Roland,

        Did you try the same solutions Clothilde mentioned?  If so then I think the most appropriate solution is to contact support as this would be considered an installation problem.  Same goes for This can be achieved really quickly using this link:

        Just fill in the form and submit it.  If you can, use the Chrome browser to log the case, you'll get more success in completing the form, and make sure your email address is entered correctly or nobody will be able to get back in touch with you.


      Related