import into termbase with sublanguages

Hi, I'm trying to import data into a termbase with sublanguages (ES-ES>EN-US/EN-GB).

I uncheck the "Ignore sublanguages" checkbox, but the import fails with the error: "Does not conform to the target termbase definition. Reason: Source: <language type="ES" lang="ES-ES"></language>"

My termbase definition has 3 languages: English (United Kingdom), English (United States) and Spanish (Spain).

My import file has terms tagged either <language type="ES" lang="ES-ES" />, <language type="EN" lang="EN-US" /> or <language type="EN" lang="EN-GB" />. No entry has all three languages, they all have ES and either GB or US (is that the problem?).

If I leave the Ignore sublanguage box checked, the data imports but the sublanguages are not recognised (all EN are terms imported as EN-GB).

What am I doing wrong? Thank you!

8 Replies Latest Replies: 18 Sep 2018 12:30 PM by Paul < 1   2  >
  • Hi

    I tried to test this using the attached and it works perfectly.

    test.zip

    So my guess is that there is a problem with your import file not matching the definition of your termbase.  Can you share your termbase and the file you are trying to import?

  • In reply to Paul:

    Thank you for your reply, Paul. I'm sure you're right.

    I get the same error when I try to import your data into my termbase (my testfile is pretty much identical to yours, except for ES-ES as source).

    I'm attaching my empty termbase.

    I see there's a difference in the structure: yours consists of Entry / Index / Term level, whereas mine has Entry / Language / Term level.  I created the termbase in the Multiterm wizard, creating a definition from scratch.

    test_termbase.zip

    ES-EN_mini-test.mtf.xml
    <?xml version="1.0" encoding="UTF-16"?>
    
    <mtf>
    
    <conceptGrp><languageGrp><language type="ES-ES" lang="ES-ES" /><termGrp><term>favor</term></termGrp></languageGrp><languageGrp><language type="EN-GB" lang="EN-GB" /><termGrp><term>favour</term></termGrp></languageGrp></conceptGrp>
    
    <conceptGrp><languageGrp><language type="ES-ES" lang="ES-ES" /><termGrp><term>favor</term></termGrp></languageGrp><languageGrp><language type="EN-US" lang="EN-US" /><termGrp><term>favor</term></termGrp></languageGrp></conceptGrp>
    
    <conceptGrp><languageGrp><language type="ES-ES" lang="ES-ES" /><termGrp><term>vecino</term></termGrp></languageGrp><languageGrp><language type="EN-GB" lang="EN-GB" /><termGrp><term>neighbour</term></termGrp></languageGrp></conceptGrp>
    
    <conceptGrp><languageGrp><language type="ES-ES" lang="ES-ES" /><termGrp><term>vecino</term></termGrp></languageGrp><languageGrp><language type="EN-US" lang="EN-US" /><termGrp><term>neighbor</term></termGrp></languageGrp></conceptGrp></mtf>
    
    

  • In reply to Stephen Waller:

    Hi

    My guess is you have an encoding error here.  Try importing this one:

    sw.zip

    All I did was remove the declaration at the beginning and it imported correctly into your termbase.

  • In reply to Paul:

    Again, thank you, Paul. It does seem to have to do with the encoding. The file you sent gave me the same "Does not conform to the target termbase definition" error, but when I resaved it, converting to UTF-16, I no longer got the error, although no data was imported. Kind of a step in the right direction, I suppose.
    Can you tell me where I can learn out about the encoding of the termbase? The Wizard seemed to output UTF-16 by default, although the original Excel file was imported from text as UTF-8. Or should I forget the Wizard and use the Glossary Converter?
    Thank you for your help!
  • In reply to Paul:

    I've just tested it and the Glossary Converter does produce the desired output, so clearly I should stick to the Converter. Thank you!
< 1   2  >
Related