2017 - Object reference problem with comments after update to 14.1.10018.54792

Hello,

After updating my Studio 2017 to version 14.1.10018.54792 last weekend, I now get the good old "object reference not set" error message if I try to save a translation file with a comment added to the target text. So far I've only worked on DOCX files this week, some received in Studio packages and some included in local projects. The error occurs when I try to save in Studio, have not tried "Save Target" as I cannot even save the SDLXLIFF files. The error does not occur if I delete all comments from the translation.

I tried the KB for help, but could not resolve this problem nor did I see it in the Known Issues. How can I get comments to work again?

Attaching the latest stack trace below.

Top Replies

Parents
  • Hello,

    I have exactly the same issue. I did not notice exactly when the problem started, but I am using the same version/update as the original poster (Trados Studio 2017, version 14.1.10018.54792). I can insert a comment into a target segment, but as soon as I click save I get the "Object reference not set..." error message. If I delete the comments, I can save the file(s). The problem seems to occur irrespective of the source file format (have tried with PPT, Word and Excel - all of which I could previously add comments to with no problems at all). I also have the Comment View plug-in installed (but this was installed long before this issue started, and has never generated any problems that I am aware of).

     have you been able to resolve the issue?

    Thanks!

    Hayley

    PS. The error log details appear to be identical to those posted by TK:

  • Hello @ 

    Unfortunately there was no further communication after my last reply/request, so we don't know if the situation is ongoing or not.

    Its worth noting TK said-

    I tried to replicate the problem with test projects today, but no luck so far. There must be something I'm missing compared to actual projects, but I cannot figure out what it is yet (file formats, virtual merge, software versions... could be any number of things). New projects next week should show if the error persists for another week.

    This appears to indicate that the file itself is the issue and not Studio per se.

    Maybe try opening the file in Single File translation mode- then immediately closing (Save Target As)- this might give an indication of problems with the file itself.

  • Thanks for the reply, but I'm not sure whether this is relevant or not: in my case the issue has occurred several times over the last couple of months, i.e. in several different projects. Is there anything I can send you to allow you to look at the issue further? Hayley

Reply Children