2017 - Object reference problem with comments after update to 14.1.10018.54792

Hello,

After updating my Studio 2017 to version 14.1.10018.54792 last weekend, I now get the good old "object reference not set" error message if I try to save a translation file with a comment added to the target text. So far I've only worked on DOCX files this week, some received in Studio packages and some included in local projects. The error occurs when I try to save in Studio, have not tried "Save Target" as I cannot even save the SDLXLIFF files. The error does not occur if I delete all comments from the translation.

I tried the KB for help, but could not resolve this problem nor did I see it in the Known Issues. How can I get comments to work again?

Attaching the latest stack trace below.

Parents Reply
  • In fact, I've just created a fake project containing one Word file, one Powerpoint file and one Excel file, each with different types of text (normal, text box, table).
    As soon as I add a comment to a target segment and hit save, the 'Object reference...' message pops up and stops me saving the files.
    I've tested this on each line of my fake file in turn, and I get exactly the same behaviour every time (see screenshot below).

    UPDATE: The error only seems to occur when I open multiple files within a project together (merged view). In my test project, if I open each test file separately, I can (for now...) insert comments and save the files.

Children