QA for forbidden terms

Hi there,

I want QA to check if million is not translated as billion in any segment.

I added the term to my TB marking its correct equivalent as "Right" and the prohibited term as "Wrong" choosing from the picklist attributes I preset for this descriptive field.

In the Terminology Verifier I ticked the checkbox "Check for terms which may have been set as forbidden" and selected "Wrong" as forbidden value (and left "Right" unchecked).

Now, the QA runs and throws an error message for all the segments where million or billion is used, even if used correctly (i.e. with the term marked as "Right").

Any idea?
Thanks, Levente

Parents
  • Hi ,

    I just moved your post into the MultiTerm forum but it just occurred to me that perhaps you have used the Language Cloud (Beta) for your termbase? If you have then I think this is probably why the verification doesn't work as I don't think this is supported with the Language Cloud Terminology solution.
  • Thank you, Paul, for moving the topic to where it belongs.
    Actually, I don't use the Language Cloud yet, so the issue has to do with normal desktop TB usage.
  • Hello,

    I realise this post is more than 3 years old, but it seems to describe exactly the same problem as I'm having.

    1. If I set a term as "Forbidden" in my Termbase, it gets flagged up as forbidden in every target segment where it occurs, irrespective of whether or not the source segment contains that term. Is that the intended behaviour of the term verification settings?

    2. you mentioned a regex workaround to flag up accidental errors like "billion" instead of "million". Which settings can you enter this in? Would it be possible to give me more details?

    Many thanks,

    Hayley

  • Hello Hayley,

    To use Norah's solution follow these steps:

    Options > Verification > QA Checker 3.0 > Regular Expressions

    Check "Search regular expressions"
    Description: Give a friendly name to the RegEx pattern
    RegEx source: Add source segment term
    RegEx target: Add forbidden target segment term
    Condition: "Report if both target and source RegEx patterns match"
    Check "Ignore case"
    Action: "Add item"

    You can add as many patterns as you want.

    The above RegEx pattern tells QA Checker to trigger a warning when  "millió" appears in the source segment and "billion" in the target one. It does the job, although it will also (erroneously) flag segments where both "million" and "billion" appear (correctly), but this is quite rare and I can live with it.

    Also, try to experiment with the options in the Conditions dropdown list!

    Best,

    Levente

  • The regex pattern can be extended to prevent the problem when "million" and "billion" are both present, by adding a negative lookahead (posit the absence of the correct term).  

    (?!.*million)^.*billion

    But as you mention, this effort might not be "cost-effective".

  • Thank you very much . I've set mine up to flag any target segment that contains thousand, million, billion and Euros regardless of what's in the source. These words only occur occasionally in the kinds of text I translate, so that's sufficient for me.

Reply Children
No Data