Object reference not set to an instance of an object - adding terms to a termbase

Hi everyone,

I'm using Studio 2017 which has been fine, until recently when *all* my termbases stopped working.

Any time I try to add an entry I get the error message "Object reference not set to an instance of an object". The termbase viewer still works and any terms already in the termbase work, but I can't add anything else.

I've searched the community and it's an error message that comes up a lot, but I can't seem to be able to fix it!

I've tried "reset window layout", reinstalling multiterm and deleting all of the Trados files I was using when the problem started (so all MultiTerm files, sdlxliffs etc).

I've started a new project now in a different language combination, so not using any common termbases, and I still get this error message. It's starting to drive me a bit insane!

If anyone has a solution for this I will be eternally grateful. For the moment I'm going to try uninstalling then reinstalling both Studio and MultiTerm...

Catriona McCabe