Multiterm ignores sublanguages when importing

Hi,

 

I have some problems with Multiterm 2017 when importing data wich was originally converted from Excel into .mtf.xml with Muliterm Convert 2017.

The source Excel file is a very simple one: 1 column for source, 1 column for target, 1 column for information and 1 column for abbreviation source. All languages have separate Excel files as the terms differ.

 

When I tried to make a termbase with several languages and sublanguages, Multiterm does ignore the next sublanguage each time. For example, if I import de-AT, de-CH and de-DE, only the first of the sublanguages remains shown in Multiterm, altough there is an empty entry for the next sublanguage.

I checked the settings several times, I tried numerous approaches, like having the source language as sublanguage (English United Kingdom), clicking the checkbox "Ignore sublanguages", literally everything.

 

 

   

As you can see, the Swiss entry remains empty even if I select Swiss German from the dropdown, and the Swiss term becomes Austrian even if I selected the right sublanguage when importing.

 

Do you know if I missed a step or is this a bug?

 

Best regards,

Adam Biczo