I can't launch MultiTerm Desktop 2019

since yesterday I can't open my MultiTerm Desktop (version 2019). The starting window appears with standard informations such as Initializing views / Loading Terms View / Showing application window but finally I can't launch the program (although there's an icon of it on the taskbar - when I click it nothing happens). It might have to do something with the latest Windows 10 update, I guess. Previously everything worked fine and all the other SDL programs are still OK.
I've already tried these solutions:
- Control Panel > Programs > Programs and Features > Repair
- Program Compability Troubleshooter
- uninstalling and reinstalling MultiTerm
but none of them worked. Any ideas how to fix it?
Thanks in advance

  • Hello  ,

    There are a couple of possibilities here.

    If you can see the icon, but MultiTerm does not open, it could be simply this is opening 'off screen'...

    Please try the following-


    If this fails, please try and install the components manually- Navigate to the following folders 

    C:ProgramData\Package Cache\SDL\SDLTradosStudio2017\modules:
    (just double-click each module in turn to manually install)

    Please note you will need to be logged on as admin to perform all the necessary updates.

    Are the issues now resolved?

  • Hello Steven Whale

    I experienced the same issue today (8th Feb 2019) as I installed SR1/CU2 for both Studio 2019 and MultiTerm2019.

    I used both of your fixes to resolve the situation but it wasn’t straightforward and I still have a (hopefully) minor issue with MultiTerm 2019 (the "Check for Updates" option is now disabled), which I will get back to at the end of this post.

    1) The first part of this post is aimed at helping users with issues after updating MultiTerm 2019 and Studio 2019 to the latest cumulative updates (CU2/SR1).

    I was stuck in an "install groundhog day" loop (affecting both Studio 2019 and MultiTerm2019), whereby the first part of the installation ("Installing Suite repair utility", "Installing MS Visual C++" etc, "Removing older versions") was going well until "Windows must be restarted for a successful installation. Would you like to restart now?" message. Whether I said Yes (restart now) or No (manual restart later), instead of finalising the installation after restart, it would start the whole process all over again from scratch (asking me to restart etc.)!

    For Studio 2019, I eventually managed to solve the problem (my version is now the latest one:, executing all 3 .MSI files (TradosCompatibility2.msi + TranslationStudio15.msi + WorldServerComponents.msi) under C:\ProgramData\Package Cache\SDL\SDLTradosStudio2019_SR1\modules

    For MultiTerm 2019 solving the issue was trickier as it was twofold.

    I also executed the .MSI files (MTConvert15.msi + MTCore15.msi + MTStudio15.msi + MTWidget15.msi) under C:\ProgramData\Package Cache\SDL\SDLMultiTermDesktop2019\modules

    This indeed reinstalled MultiTerm 2019 properly to the latest version (

    I could see the shortcuts on my desktop and all the components of the programmes appeared in the Control Panel (Control Panel\Programs\Programs and Features). Unfortunately, when I tried launching MultiTerm 2019, I would only see the starting window (just like in Piotr LeÅ?niewski’s case) and the MultiTerm 2019 interface wasn’t showing.

    I use 3 screens (2 monitors connected to my laptop) so I am familiar with the notion of a programme opening 'off screen', as you described. The only issue was that the "MOVE" option described in the URL you provided was not available. (I’ve noticed it’s not always available in Windows 10).

    Instead my alternative fix was:

    -turn my laptop off

    -disconnect my two monitors

    -start my laptop again and launch MultiTerm (still ’off screen’)

    -launch the Task Manager (Ctrl+Alt+Del), select MultiTerm and then "Maximise" (sometimes "Bring to front" can also work)

    -This brought MultiTerm back and all I had to do was manually resize of the actual MultiTerm window

    -Finally I closed all programmes, reconnected my monitors, launched MultiTerm and Studio 2019 and both appeared properly

    2) Now, as mentioned at the beginning of this post I still have one remaining issue with MultiTerm 2019: the "Check for Updates" option is disabled, whereas it IS in Studio 2019. I wonder if it’s got anything to do with having to install the Cumulative Updates manually as opposed to automatically.

    Can you tell me if this greyed out "Check for Updates" is normal?