Error when trying to open a termbase

I am running Studio and Multiterm 2017 on Windows 10. I have read the existing articles on my issue(s), but have been unable to resolve the problem. 


After a recent software update, it became impossible to open Multiterm Desktop, although the connection to Studio was still working and I was able to see terminology. Today, Multiterm stopped finding terms that I know are in the TB. When I try to do a Quick Add of an existing term while Studio, I also get the message that the term is already in the TB, but when I search for the term or open a segment containing a term that I know is in the termbase, nothing shows up.

Opening Multiterm directly was still not possible. There are no Advanced Options shown for any of the SDL products under Apps & Features, so I don't have a Repair option. I therefore uninstalled and reinstalled Multiterm 2017 from the previously downloaded installation file. I can now open the program, but terms are still not found while I work in Studio. Also, when I try to open a termbase file on my computer (no server connection requested), I get the error " A connection to SDL Multiterm Server unknown could not be established". I have read existing articles about this issue, I have tried reinstalling from the individual msi files, and renaming the Multiterm folder and restarting the software. Nothing has worked. 

Also, while I trying to figure out this problem, I noticed that SDL Multiterm 2017 SR1 - Remove suite of Products shows up under Apps & Features in Windows, but I don't see the application in the Start menu and cannot find it with a search.

Multiterm version after reinstall is 14.1.2441.0

Studio version is 14.1.10015.44945

Any ideas?