Multiterm uninstall error: Setup did not complete. The error is: Setup has detected a higher version of this product already installed. If you still wish to install this version, you must remove the other version first.

As I was uninstalling Studio and Multiterm 2019 today due to a lot of crashes in Studio (I was able though to reinstall successfully Studio), I could not uninstall Multiterm under Apps & Features:

If I hit Uninstall, it launches the wizard and at the very end of it, I get this error message:

However, if I go to the Start menu Multiterm is gone, I can only see a few folders left under the Programs folder and under the Documents. 

I tried launching the latest version executable I just downloaded today, but I still get the same error message above. I am working with Win 10 and I noticed that the crashes started when I was trying to open older projects today, but at least that issue was solved by reinstalling Studio. Now I just need to get the latest version of Multiterm on my machine. Please advice.