Reinstalling Multiterm 2019

Hello. I am trying to reinstall Multiterm 2019 (I was told I needed to reinstall it in order to get the Widget). Now when I try to install it, I get a box saying that: "Set up did not complete. The error is: Set up has detected a higher version of this product already installed. If you wish to install this version, you must remove the other version first." But I did uninstall all Multiterm 2019 files except the "SDL Multiterm- Remove suite of products", which I can't figure out how to remove it. Please, Help!