Term Recognition not working

I have been constantly annoyed be term recognition not working consistently. I am an intensive TD user and might have many TDs opened sometime. What I observe is too too often - Term existing in the TD are now recognized - not highlighted and not in the Term Recognition window. But I can search for them and here they are!!!!
This was the case with 2017, with 2019 and now with 2021.… still not fixed.

Earlier, the speed of the various screens, adding a TD or refreshing a TD was a major issued and that has been handled once for all - great.

Now that issue on TD is the next one inline to be resolved as well once for all, as what the use of a TD and the system can't use them properly?!

If you are experiencing the same problem - please post it  - so we can get this resolved!!!

  • I've noticed this for years too. When it starts happening I restart Trados Studio and that seems to fix it.

  • I have a similar issue with term recognition not working consistently with 2021 (2017 and 2019 were the same). I already tried to uncheck lookahead, restart Studio, change the layout of the TB window, but nothing helped.

    The recognition works for some of the first segments and suddenly stops working for the next segments, then works again for some segments (if I am lucky) and so on. It moreover does not always recognises all words in a segment, even if the terms are all present in the TB.

    I sincerely hope there is a way to fix this, since it is a real massive loss of productivity!

  • Same problem here, too, and I have also had it in all versions of Studio, up to the latest version currently available.

  • Same for us here. And re-organizing TBs is not an option, as we're using GroupShare and server TBs. Even then, term recognition does not work properly, much to our translators' aggravation as TBs are crucial to translation quality and coherence when working in a large team.