Term recognition not working in Trados Studio 2021

Dear All,

I have recently (since the last update i.e. SR1?) noticed that term recognition has abruptly stopped working in Trados Studio.

I can literally search for a term in the linked Multiterm termbase and find it, but when I go to the segment with the exact same term in it, it is not found.

Exporting the terms, making a new termbase based on the old termbase and then importing the terms makes zero difference. The new termbase is also useless.

However:

- Terms are clearly being found in an F8 search

Versions used:

SDL Trados Studio 2021 SR1 - 16.1.6.4276

SDL Multiterm 2021 SR1 16.1.1.541

Fortunately, I don't use Studio as my main CAT but this is still unacceptable.

Ed

Top Replies

  • I have Trados Studio 2019 and often have the same problem: term recognition suddenly not functions. My solution, reorganise the TB and restart Trados Studio. Depending on the TB activity, this must be done often. 

  • That's interesting to hear Anthony. I've not experienced this before and I have been using Trados on and off since the 2015 version. Your solution did not work for me, unfortunately. I tried reorganising first and, when that didn't help, I then recreated the termbase by exporting its terms and using it as a model to create a new termbase in Multiterm. That also did not work.

    But, as said, the terms are being found correctly with an F8 search. And they can be searched for using Termbase Search perfectly. It is specifically the Termbase Recognition feature that is not working.

    I've always viewed Trados Premium Support as an option. It seems it is instead to be recommended if you want this kind of thing fixing.

  • Hello   

    Do you have your termbases stored locally or in the cloud?

    There are a few suggestions listed here that may help- especially perhaps option D (adding exceptions to security suite)

    gateway.sdl.com/.../communityknowledge

  • Hi Steven,

    Many thanks for replying to my issue here in the forum.

    Your list of possible solutions got me thinking, although none actually worked for this particular issue.

    It has nothing to do with termbase searching per se. I can find the terms using Termbase Search and F8 with no problem but the Term Recognition window remains stubbornly empty, regardless of what segment I am in. I can literally input the term from the left-hand German segment into the Termbase Search and it finds it, even though the Term Recognition window is blank. And even when an F8 check tells me there is a term error, and specifies which one, it does not show up in Term Recognition.

    However, I should note that I work on resources supplied by customers, I do not create projects or packages myself.

    And lo and behold, the issue appears to be affecting some customers - and even some projects from some customers - but not others.

    Steven: do you have any idea how I could check the version of Studio used to create a particular package?

    I can only imagine that must be the problem here: the customer version is causing termbase problems with my version of Studio.

    I have just checked (after resetting hitlist settings, etc. for term searching) and some projects appear fine, with term searching as normal. While others do not.

    If I could somehow distinguish between one project and another - the Studio version? - then perhaps I can inform my customers better as to the problem.

    Thanks,

    Ed

  • Hello ,

    Reinstalling the software doesn't always fix issues errors (depending on what is causing the issue.

    Instead, I would probably suggest a reset/repair.

    https://gateway.sdl.com/apex/communityknowledge?articleName=000001414

    Then should the issue persist, we can ask the support team to have a look for you.

  • Hi Steven,

    Thanks for the information, I'll see if that helps.

    Sincerely,

    Ed

  • Hi Steven,

    The repair didn't change anything but Workaround 2 instantly put things right.

    I'll go straight to that step in future if anything stops working as it should.

    Thanks again for suggesting a solution,

    Ed