How to convert a TBX file in to .sdltb file for SDL termbase


I am using SDL Studio 2015 SR2 with SDL Multiterm 2015 SR2.

I have received a termbase file from a customer (say "Termbase TBX") an XML document. I need to convert it to a .sdltb file for use with SDL Multiterm.

Could you someone tell me to go about it please?

Can Multiterm itself handel .xml termbase document or do I need to use a converter first (which one?).

Thanks for your support in advance

Best regards

Shyam Gupta 

Parents Reply Children
  • Hi Paul, hi Jerzy,
    Unfortunately I cannot contact the customer to get permission to share TBX file here (as you know, Yesterday was a public holiday in Germany and today is the so called "bridging day").

    However I have the following pieces of information:
    1. The TBX file has been extracted from a SDL Termbase using the export function
    2. The log file sent by the customer appears to be quite ok, except for the fact that "export type = User defined".

    Probably this is the cause of the error - I don't know what export option the customer has selected.

    I myself have tried to export one of my existing .sdltb files using SDL termbase export function and it created an .xml file without problems. I could reconvert this .xml file into SDL Termbase file using the Glossary Converter without problem. Indeed comparing the log file, I found that in my case the "export type" was given as "default" and not "user defined". This was the only difference I could see.

    Is there any other possibility to convert the .xml file into .sdltb (perhaps using the so called "definition file.xdt".
    Is this described somewhere in SDL documentation or in a SDL video?

    Finally, if I were to send to you the .xml file, how could I possibly do that - attach to this reply?
    Unfortunately I don't seen any button to attach/upload a file to this reply. Could you kindly inform me also on this please?

    Thanks for you help in advance
    Best regards
  • Hi Paul, Jerzy,
    The "export type" shown in my export test case was "Vollständig" (Complete) and not "Default" as mentioned in my response above.
    I am sorry for have made that mistake.
  • Hello Shyam,

    If the xml won't convert with the Glossary Converter then I doubt MultiTerm will do it either, but you could try using MT Convert. You build the definition with MultiTerm Convert in a similar way you would with the Glossary Converter. So maybe worth a try. It feels as though there is something wrong with the file though.

    If you were to attach files to this thread perhaps review this post, it explains how to do this:


  • Hi Paul and Jerzy,

    Finally, here is some good news I wish to share with you.

    I created a new termbase in SDL Termbase using the "Definition file" (.xdt) and then imported the .xml file into it.
    And it worked. I now have a proper .sdltb file which I can work with.

    Many thanks for your guidance - which lead to the solution.

    Best regards