The file cannot be opened in Microsoft Excel

I am trying to upload a glossary in xls format to MultiTerm Converter but the programme replies with "The conversion option could not be initialised properly. The file cannot be opened in Microsoft Excel". It is the first time I have used MultiTerm Converter.

I use MS Office 2016. Please note that I cannot use Glossary Converter either.

Thank you in advance for your help.

Chiara

Parents
  • Dear Chiara, dear all,
    It´s the first time I´m trying to work with Multiterm, and I´m having exactly the same problem. I can´t convert my excel file with Multiterm convert, and I get the message "file cannot be opened in Microsoft Excel". When I try to do it with the Glossary Converter, again I get the message that the Excel file can´t be found and I should try to repair my excel installation.

    So I run a repair-installation, but without any success, and again I deinstalled Office 2013 and installed it again, with the same result. First I had quite a complex excel-file, but then I tried with a very simple one (three columns with 3 different languages, all fields filled out), with the same result, no matter whether I used Excel 97-2003(xls)-files or xlsx-files.
    Anybody can give me an idea what else I could try to do?
    Many thanks and kind regards,
    Isabel
  • Hi , make sure you have the latest version of the Glossary Converter installed.
  • Hi Paul,

    I just deinstalled SDL Trados & Multiterm & Glossary Converter and installed them again. The same messages appear. +
    one message in Glossary converter:

    Microsoft Excel can´t be started. Please make sure, MS Excel is installed on this computer".
    20/09/2018 15:44 Failed to instantiate MS Excel: System.InvalidCastException: The COM-object of the type "System.__ComObject" cannot be converted into the interface type "Microsoft.Office.Interop.Excel.Application". This process could not take place, as the QueryInterface-call to the COM-component for the interface with the IID"{000208D5-0000-0000-C000-000000000046} could not be carried out due to the following error: Library not registered. (Exception of HRESULT:0x8002801D (TYPE_E_LIBNOTREGISTERED)). at Sdl.MultiTerm.Tools.GlossaryConverter.Helpers.MsExcelFactory.
    Initialise (Boolean force)
    (all translated from German)

    Many thanks in advance...
  • Hi  

    This is a known issue... you can see this in the GC help file:

Reply Children