Grammar checker returns ??? when errors

Hi,

 

I installed the grammar checker plugin v1.3 for Studio 2015 SR2 12.2 on a new Windows 10 Pro (1607) PC.

However, each time I make a grammar error, all that this grammar checker shows are 3 question marks (???), but no description of the errors I made.

I also used the same version of Grammar Checker on a Windows 7 Pro PC ansd there Grammar Checker does indeed gives a description of the errors I made.

How can I make Grammar Checker work on my Windows 10 PC? Any suggestions?

Thank you.

Best regards,

Eric

 

  • Hi Eric,

    We are investigating this in another thread at the moment.  It may be that Office 365 is the culprit here as it does not provide all the components we need to be able to hook into the Word features.  It works fine if you have the MSI version of Word installed.   might be able to update this thread next week sometime.

    Regards

    Paul

  • Hello Paul and colleagues,

    Any news regarding Grammar Checker with Office 365? I should need it next week, because I'll then start Monday a large translation project into Dutch. Until now, I was translating into French and I could use the Antidote app (I have a licensed Antidote fully updated), so I didn't really need Grammar Checker for this, but now it really would be nice to have it for Dutch, otherwise I'll have to reinstall a very old version of Office, Office 2007...

    Please advise.

    Best regards,

    Eric
  • We're struggling with this because we cannot reproduce the problem at all.  We've installed various kinds of MSOffice, installed in different ways, and we don't have a problem.  

    However, maybe worth seeing if toggling this option makes a difference?  So if it's checked uncheck it and run verification again:

  • Hi Paul,

    Spooky... As it often is the case with Windows...

    Thank you for your reply and time.

    When I uncheck "Show error description", the app returns with the message "The target segment contains a grammar error".
    When I check this case, the message is "!!!" (and not "???" anymore, strange...). Checking or unchecking that case doesn't really change the problem, I'm afraid... :-(

    I also disabled the UAC to see, but got the same messages, unfortunately.

    I also downloaded the LanguageTool, but the problem there is that I get the message Cannot connect to server... Also :-(.

    Note that I installed MS Grammar Checker on a brand new PC that I installed 2 weeks ago, so this PC is still quite clean regarding Windows 10 (1607), I think...

    So there must be a reason why Grammar Checker doesn't show the right error messages on my new PC, I'm afraid. You could if needed connect to my PC for this MS Grammar Checker problem.

    Best regards,

    Eric
  • Hi Eric,

    As Paul said we're struggling at this moment with the plugin because we can't reproduce the issue in order to fix it.

    Could you please  test this version, you'll receive a warning message because is not a signed plugin, is just a version for testing. I added a logging system to this version, hopefully we'll catch some errors.

     

    After you test it could you please send me the log file, you can find it at this path: C:\Users\[UserName]\AppData\Roaming\SDL Community\GrammarChecker , where [UserName]- is your account name.

    Regards,

    Andrea.

  • Hi Andrea,

    Thank you for your help and sorry for my late reply, as I again didn't receive an e-mail to say there was a reply for my question, although I received e-mails for Paul's replies.

    Anyway, I uninstalled version 1.3 and installed this new version, but I still get !!! when there's a grammar error (in this case the translation is into Dutch) - see this screenshot: 

    As you can't reproduce this, I start to think that the reason of these !!! lies somewhere else. The only information that I can give, is that I installed Office 365 on a brand new PC running Windows 10 Pro 64 bit (1607) fully updated and that I installed Office 365 immediatly after having installed Windows (which was in fact preinstalled), meaning that I installed Studio after Office 365.

    Maybe there's a setting that I must change in Word 365 to make Grammar Checker work correctly?

    Best regards,

    Eric

     

  • Hi Eric,

    No worries, have you checked the file from this path: C:\Users\[UserName]\AppData\Roaming\SDL Community\GrammarChecker , where [UserName]- is your account name?

    Could you please tell me is there is any message in the file?

    Regards,
    Andrea.
  • Hi Andrea,

    Sorry, I indeed forgot to attach to log files.

    I did today again a grammar check with this new version and the log was indeed modified, but remained 0 kb  and empty.  The log with previous version 1.3 is also empty and 0 kb. Do you want the log files? If so, please tell me how to attach them, because it seems I can't attach files to my replies.

    Best regards,

    Eric

  • Hi Eric,

    Thank you for replay, I'm working on a new version, I'm adding logging information, not only errors. I'm come back to you with another version in a couple of hours.

    Regards,
    Andrea.
  • GrammarChecker logs.zip

    Hello Paul & Andrea,

    Sorry, I didn't see Insert, because I was looking for Attach... 

    Please find above the logs in a zip file.

    PS: I again didn't receive an e-mail to notify me of your replies, although I checked "Notify me" in the advanced edit settings. This is one of the reasons why I don't really like to use this list = much more complicated than the Yahoo list using e-mail/Outlook [:(]. But I'll continue to use it because of better replies with it... [:)].

    Best regards,

    Eric

  • Hi Eric,

    I added some log info to Grammar plugin could you please uninstall the plugin, and install this version 1.5 and send me please the log file again?

     

    Regards,

    Andrea.

     

     

  • Hi Andrea,

    The log is now OK (I think). Please find the log here: grammarLog.zip

    Best regards,

    Eric

  • Hi Former Member,

    Eric Wouters said:
    PS: I again didn't receive an e-mail to notify me of your replies, although I checked "Notify me" in the advanced edit settings. This is one of the reasons why I don't really like to use this list = much more complicated than the Yahoo list using e-mail/Outlook [:(]. But I'll continue to use it because of better replies with it... [:)].

    One way to attract peoples attention is to name them by typing an @ symbol first and then their user name that you see when they post.  You should get an email now saying you were mentioned in this thread.

    Also, if you check your Activity tab then you will see all the threads you are personally involved in which is very handy, especially if you can't find something:

    Stick with it... after you start to learn the little tricks it gets easier and I think this medium does offer a lot of advantages over Yahoo... never mind the fact this one is full of SDL people who are willing to help in addition to all the great answers we see from other users.

    Regards

    Paul