Glossary Converterで Excel ファイル(.xlsx)からMultiTerm Termbase (.sdltb)に変換できなくなりました。



「Can’t detect MultiTerm, using Xdt/xml as termbase format instead」


おそらくらMultiTerm 2017 SR 1にアップデートしたあたりから使えなくなりました。



SDL MultiTerm 2017 SR1 -

SDL Trados Studio 2017 SR1 - 14.1.10015.44945

Glossary Converter version 5.1.6860.15775

Excel 2013





  • Hello

    The core Studio development team and the Glossary Converter developer are investigating this at the moment because it appears as though the latest updates in SR1 for 2017 and 2019 have broken the Glossary Converter.

    The workaround is to use MultiTerm Convert... the old fashioned way! This video is a little old but gives a quick example of how to use it if you're not familiar:
  • Paul,

    Any progress on this matter? It would be great if Glossary Converter could be integrated into MultiTerm as a standard feature.
    The old fashioned way is just too inefficient.

  • Hello  

    Takayuki Osato said:
    Any progress on this matter?

    Very little I'm afraid.  We have a couple of solutions that works for some but not for others so you can try these and see if it helps:

    1. Copy the file "log4net.dll" from the location C:\Program Files (x86)\SDL\SDL MultiTerm\MultiTerm15 to C:\Program Files (x86)\Common Files\SDL\MultiTerm15
    2. Download a Beta version from here - - which is just the zipped files and not a proper installer.  So unzip into your program folder for the converter and run the application.

    We have found that the first one helped a few users; the second one helped a couple of others.  Unfortunately from the several dozen users the developer shared this with only 4 responded so we're very short of feedback and have still not managed to find the real solution for all users.

    So if you try these and one works, please let us know.

    Takayuki Osato said:
    It would be great if Glossary Converter could be integrated into MultiTerm as a standard feature.

    It doesn't belong to us, and in many ways I like it better as a standalone external application.  Faster turnaround for bug fixing (normally... but this time it's not the developers fault), easier to implement new features.

  • Hello

    I am just adding my feedback regarding this issue:
    (Feedback has already been given in SDL community and also to the developer Mr. Gerhard Kordmann)

    Step 1.: Copying the log4net.dll file did not help resolve the error.
    Step 2: replacing the original folder with the contents of beta version of glossary converter.
    I am able to use the glossary converter (beta) successfully.

    Please Note:
    All these steps DID NOT help to run the regular version of Glossary converter 5.1.6860.

    Thank you always for your prompt guidance and help in this forum and I am always thankful so much to you!

    Have a nice day!
  • Hi Paul,

    I have figured out that when you get this error there is a problem with Settings.xml file in c:\ProgramData\SDL\Sdl.MultiTerm.Tools.GlossaryConverter\5.1.6860.15775 folder. When you open it, it's simply empty, so you need to copy and paste this line to Settings.xml file and save it. Command line below:

    <?xml version="1.0"?><settings><key name="MultiTerm\ServerDatabaseInfo"><value name="(default)"></value></key></settings>
  • Hi

    Thank you. That is in fact the third issue we already identified and now have a small tool created by the developer of the Glossary Converter that repairs all three problems that have been identified. This will hopefully fix the issue are any user... but it will be good to see more results from anyone affected:
  • Hello Paul,

    For the recovery of GlossaryConverter, I tried the suggested steps and I'd like to share the success story!
    Step 1: Copy the file "log4net.dll" from the location C:\Program Files (x86)\SDL\SDL MultiTerm\MultiTerm15 to C:\Program Files (x86)\Common Files\SDL\MultiTerm15
    Step 2: Download a Beta version

    Step 1 didn't work, but Step 2 worked and now I'm able to use GlossaryConverter as it was!
    Although I tried Multiterm Convert, some entries contain many synonyms using a separate character "|", which seemed nearly impossible to reconstruct from scratch (or is there a way?). It's a big relief as I can now transfer my database between excel and sdltb file for the first time since I upgraded to Trados Studio 2019 SR1.

    Thanks very much,
    Tomoko Fujii
  • Dear Martynas,

    everytime I restart the Glossary Converter, it emtpies the settings file again...

  • Copying log4net.dll worked for me o Studio2019. Thnx.
Reply Children
No Data