DeepL does not offer translation for files pre-translated by agency. Is there a solution?

I was using the DeepL app with Studio until the agency I do most of my work for switched to pre-translating most of their projects. DeepL would not provide a translation for pre-translated segments, instead giving the reason that each segment is "already translated". This was very disappointing since it was great when it worked with 'empty' segments.

I recently upgraded my Studio 2017 to Studio 2019 and installed the latest DeepL app, which was supposed to have overcome the problem of not offering a translation for pre-translated segments. I was looking forward to using it but still have the same problem. As before, DeepL will not provide a translation, giving the message that the segment is "already translated" instead.

Microsoft Translator gives translations even with pre-translated segments, so it must be possible to overcome this problem.

 

As I have resorted to using the free DeepL online translator because I can no longer use the paid app with Studio, I have ended my subscription. Once I see here that this problem has really been solved, I will consider whether to renew my subscription.