Wrong version of Community Advanced Display Filter?

This morning's RSS feed for the new version of this plugin states versions 4.3.3 and 3.9.3, but the download actually offers 4.3.4 and 3.9.4.