Community Advanced Display Filter error - Key already exists

Hi,

I've just downloaded the latest version of Community Advanced Display Filter for Studio 2019.

First, I could not open an existing file for translation. The "Key already exists" error message appeared. Then, I uninstalled the plugin, looked for duplicates (no duplicates existed), restarted my computer and installed CADF again.

Now I cannot even start Studio, and the error message "Key already exists. Parameter name: Key" appears.

Where can I download any previous version of CADF?

Kind regards

Sandor

  • I'm pretty sure you have not removed the duplicate plugin as instructed with the updated version.  To avoid all doubt please clear them all and then reinstall just the ones you need.

    Please try manually removing the plugin from all of these locations, if it’s in there, and then reinstall the latest one on the store.
    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\15\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\15\Plugins\Unpacked\
    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\15\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\15\Plugins\Unpacked\
    c:\ProgramData\SDL\SDL Trados Studio\15\Plugins\Packages\
    c:\ProgramData\SDL\SDL Trados Studio\15\Plugins\Unpacked\
  • Hi Paul,

    I uninstalled the plugin in Sdl Plugin Management, restarted my computer and checked all the xis locations you mentioned. None of them contains the CADF plugin.

    Quite strange at this point that CADF is still there in my Studio, despite the fact that it was uninstalled.

    Any idea?

    Sandor

  • Hi Paul,

    Update: I found CADF plugin under C:\Users\User\AppData\Roaming\SDL\SDL Trados Studio\15\Plugins\Unpacked\Advanced Display Filter.

    I deleted this folder but the folder with its contents is recreated upon starting Studio, and CADF is still there in studio.

  • Quite strange at this point that CADF is still there in my Studio, despite the fact that it was uninstalled.

    Any idea?

    Yes... you have not uninstalled it.  Have you done what I suggested and cleared all of these folders?  Dn't just remove what you think are the right ones, remove everything (trivial exercise to put them back).

  • Problem solved.

    As you can see in the screenshot, although CADF was uninstalled in Sdl Plugin Management, there was an Advanced Display Filter in the list. I didn't think it actually was Community Advanced Display filter., too I uninstalled it and then I could install the latest CADF.

  • ok - send me an email and we can look at this together on your computer over skype.  pfilkin@sdl.com

    Will be useful to find a problem that we are not aware of yet.