SDL Analyse - No project templates are defined (issue after update to SR2, server licence)

My company has been using this app for the last year and a half and it's really a timesaver. We have a Professional Network licence for both Studio 2017 and 2019 and the app is installed in both of the versions of the programmes. We've had no issues (except the occasional "Service not working" which we were able to reslove) so far. 

A couple of days ago, we've updated the 2017 version to CU15 (we were behind on the updates), the 2019 version to SR2 and also installed MultiTerm for both versions. Then we installed the 3.12.1 version of SDL Analyse as it is compatible with SR2. However, after starting up the app for the first time after the updates, the issue "No project templates are defined" appeared. 

Our IT company tried to reinstall the app, made sure we have no old Studio versions left over, tried the solution in this thread ( and made sure we have folder c:\Users\[USERNAME]\AppData\Roaming\SDL\ProjectApi with the Sdl.ProjectApi.xml file (pointing to the correct LocalDataFolder location) there for every user, all to no avail. What is more, the appearance of the "No project templates are defined" error is that much stranger since we do not actually use project templates ...

This thread ( seems promising but offers no solutions. :) Would anyone be able to help me out?

Top Replies