Studio export analysis report

Hi, we're trying out the new studio version. Just installed this plugin ;

appstore.sdl.com/.../.

But I' m not able to export reports in csv format...

I get this message (apologies; it's in Dutch) :
de objectverwijzing is niet op een exemplaar van een object ingesteld

Can anyone help?

Parents
  • Hello  ,

    The message- ' Object reference not set to an instance of an object ' is quite generic and doesn't tell us very much unfortunately.

    As you mentioned 

    Hi, we're trying out the new studio version. Just installed this plugin ;

    ...Im wondering whether you are you working for an organisation perhaps?

    Has the plugin been installed with admin rights? Do you have admin rights on the computer?

    Would you be able to post the full error stack (if you save the XML to your desktop, you can then attach this to the thread

    Also, could you let us know which version of Studio you are using and whether this is up to date and the operating system please.

Reply
  • Hello  ,

    The message- ' Object reference not set to an instance of an object ' is quite generic and doesn't tell us very much unfortunately.

    As you mentioned 

    Hi, we're trying out the new studio version. Just installed this plugin ;

    ...Im wondering whether you are you working for an organisation perhaps?

    Has the plugin been installed with admin rights? Do you have admin rights on the computer?

    Would you be able to post the full error stack (if you save the XML to your desktop, you can then attach this to the thread

    Also, could you let us know which version of Studio you are using and whether this is up to date and the operating system please.

Children
  • Hi 

    Plugin has been installed with admin rights now. But still doesn't work. I'm attaching the error message for you.

    sdlerror-2019123-11h54m57s.sdlerror.sdlerror.xml
    <SDLErrorDetails time="3/12/2019 11:55:11">
      <ErrorMessage>De objectverwijzing is niet op een exemplaar van een object ingesteld.</ErrorMessage>
      <Exception>
        <Type>System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</Type>
        <HelpLink />
        <Source>Sdl.Community.Toolkit.Core</Source>
        <HResult>-2147467261</HResult>
        <StackTrace><![CDATA[   bij Sdl.Community.Toolkit.Core.Services.StudioVersionService.GetStudioVersion()
       bij Sdl.Community.ReportExporter.Helpers.Help.GetInstalledStudioMajorVersion()
       bij Sdl.Community.ReportExporter.Helpers.Help.GetStudioProjectsPath()
       bij Sdl.Community.ReportExporter.ReportExporterControl.InitializeSettings()
       bij Sdl.Community.ReportExporter.ReportExporterControl..ctor()
       bij Sdl.Community.ReportExporter.ReportExporterViewPartAction.Execute()
       bij Sdl.Desktop.IntegrationApi.AbstractAction.Sdl.Desktop.IntegrationApi.Extensions.Internal.IAction.Execute()
       bij Sdl.Desktop.IntegrationApi.Internal.Adaptors.InternalActionAdaptor.Execute()
       bij Sdl.Desktop.Platform.Implementation.CommandBars.ActionService.<>c__DisplayClass30_0.<ExecuteAction>b__0()
       bij Sdl.Desktop.Logger.Log.Resources(Object message, Action action)
       bij Sdl.Desktop.Platform.Implementation.CommandBars.ActionService.ExecuteAction(IAction action, ActionOrigin origin, Boolean allowToggle)
       bij Sdl.Desktop.Platform.WinForms.IgCommandBarAction.Execute()
       bij Sdl.Desktop.Platform.WinForms.IgCommandBarAction._lazyButtonTool_ToolClick(Object sender, ToolClickEventArgs e)
       bij Infragistics.Win.UltraWinToolbars.ToolBase.OnToolClick(ToolClickEventArgs e)
       bij Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.OnToolClick(ToolClickEventArgs e)
       bij Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.FireEvent(ToolbarEventIds id, EventArgs e)
       bij Infragistics.Win.UltraWinToolbars.ToolBase.OnToolClick()
       bij Infragistics.Win.UltraWinToolbars.ButtonToolUIElement.DoClickProcessing(MouseEventArgs e)
       bij Infragistics.Win.UltraWinToolbars.ButtonToolUIElement.OnMouseUp(MouseEventArgs e)
       bij Infragistics.Win.ControlUIElementBase.ProcessMouseUpHelper(Object sender, MouseEventArgs e)
       bij Infragistics.Win.ControlUIElementBase.ProcessMouseUp(Object sender, MouseEventArgs e)
       bij Infragistics.Win.Utilities.ProcessEvent(Control control, ProcessEvent eventToProcess, EventArgs e)
       bij Infragistics.Win.UltraWinToolbars.UltraToolbarsDockArea.OnMouseUp(MouseEventArgs e)
       bij System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       bij System.Windows.Forms.Control.WndProc(Message& m)
       bij System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       bij System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       bij System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)]]></StackTrace>
      </Exception>
      <Environment>
        <ProductName>SDL Trados Studio</ProductName>
        <ProductVersion>15.0.0.0</ProductVersion>
        <EntryAssemblyFileVersion>15.2.0.1041</EntryAssemblyFileVersion>
        <OperatingSystem>Microsoft Windows 10 Business</OperatingSystem>
        <ServicePack>NULL</ServicePack>
        <OperatingSystemLanguage>1043</OperatingSystemLanguage>
        <CodePage>1252</CodePage>
        <LoggedOnUser>AzureAD\Test</LoggedOnUser>
        <DotNetFrameWork>4.0.30319.42000</DotNetFrameWork>
        <ComputerName>TEST-COMPUTER</ComputerName>
        <ConnectedToNetwork>True</ConnectedToNetwork>
        <PhysicalMemory>16735156 MB</PhysicalMemory>
      </Environment>
    </SDLErrorDetails>

  • Hello ,

    Sorry I didn't deeply earlier- (see the top tip below). 

    Unfortunately i have not been able to replicate the issue-

    Having looked at the error stack- It looks like the app cannot determine your Studio version correctly.

    Could you please close Studio- completely remove the plugin- (ensuring no trace in the following folders)

    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\15\Plugins\Packages\

    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\15\Plugins\Unpacked\

    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\15\Plugins\Packages\

    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\15\Plugins\Unpacked\

    c:\ProgramData\SDL\SDL Trados Studio\15\Plugins\Packages\

    c:\ProgramData\SDL\SDL Trados Studio\15\Plugins\Unpacked\

    c:\Users\[USERNAME]\AppData\Roaming\SDL Community\

    Now reinstall the plugin (you MUST have admin rights) version 3.0 for Studio 2019 and install-

    Now restart Studio (again this must be as ADMIN)

    Then restart Studio, ensuring you run this as Admin-

    Now try and do the analysis export- ddoes this work?

    If you need more time for testing- Annelies will be able to help you here.