Can't use the Deepl plugin

Hi everyone,

I recently bought sdl trados studio 2019 and thought that it was a good idea to add the Deepl plugin. I bought Deepl pro, then I went to the appstore, downloaded the plugin and then, when I double clicked on the file, nothing happened. I clicked again and again, tried to click on "Open with..." but nothing happened at all. I downloaded it again but nothing happened either. I tried to add another plugin to see if it was just Deepl but it was the same : I click, there is a little thing that shows that it was correctly executed and then nothing.

Has anyone here encountered the same issue and then found a solution? I kind of need this tbh, and the Deepl subscription is also a little bit expensive so I really need your help.

Thanks a lot for your answers.

Parents Reply Children
No Data