Deepl plugin - new version: issue

I have downloaded and installed Deepl new pluging on the instance Studio 2019 of one team mate and get Following message when I try to pretranslate with Deepl:

Impossible de charger le fichier ou l'assembly 'Newtonsoft.Json, Version=4.5.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' ou une de ses dépendances. La définition trouvée du manifeste de l'assembly ne correspond pas à la référence de l'assembly. (Exception de HRESULT : 0x80131040)

Any idea what it could be related to?