DeepL plugin - not all segments are pretranslated

Last week I updated my Trados client to 15.2.5.2145 and installed the DeepL plugin.

I have tested with different file types (docx and xliff) and language pairs and have found each time that around 4 - 5 % of the files are not pretranslated. When I click into the empty segments, however, I see that DeepL translations are available.

Does anyone have an idea what could be causing this? Manually inserting the translations is - depending on the file size - painstaking.

Thanks in advance.

Rachel

Parents
  • I was testing a fix in the plugin for something else this morning and purely by accident managed to reproduce the problem you have explained. So, in case this helps you here's what the resolution was to the problem.

    You have two locations where you can set the minimum translation match value in your project settings.

    Here:

    And here:

    When you are pre-translating with a TM and also Machine Translation it's important that you take both these settings into consideration.  The first one, under Search is there to set the minimum value at which a result will be returned from your TM at all.  The second one, under Pre-translate Files, is there to set the minimum value at which you wish your file to be pre-translated.

    So if you set the Search criteria to 60% and the Pre-translate value to 100% with a TM that could provide matches between 60% and 100% then a pre-translate using MT could result in something like this:

    This is because the MT will only be applied where there is no match from your TM based on the Search criteria which was 60%.  In this case the missing segments actually have a TM match at 62%, 63%, 93% and 65%.  All above the 60% I set, but below the 100% pre-translation setting.  Since the option says this:

    "Apply MT when no match is found", so it only applies the MT where there is actually no value in the TM at all.  Since the default value in here is 100% failing to change this value too would be easy to miss.  So if I actually wanted to see MT results for all of these I need to tell Studio it's pre-translating to the same value as the Search, so I should raise my minimum match value to 100% in the Search as well.  When I do that the result is this:

    If I prefer to see results from my TM for all matches above 60% then I should lower the minimum match value to 60% in the Pre-translate as well.  Then I see this:

    I hope that makes sense to you and even more so I hope this resolves the problem you were having?

Reply
  • I was testing a fix in the plugin for something else this morning and purely by accident managed to reproduce the problem you have explained. So, in case this helps you here's what the resolution was to the problem.

    You have two locations where you can set the minimum translation match value in your project settings.

    Here:

    And here:

    When you are pre-translating with a TM and also Machine Translation it's important that you take both these settings into consideration.  The first one, under Search is there to set the minimum value at which a result will be returned from your TM at all.  The second one, under Pre-translate Files, is there to set the minimum value at which you wish your file to be pre-translated.

    So if you set the Search criteria to 60% and the Pre-translate value to 100% with a TM that could provide matches between 60% and 100% then a pre-translate using MT could result in something like this:

    This is because the MT will only be applied where there is no match from your TM based on the Search criteria which was 60%.  In this case the missing segments actually have a TM match at 62%, 63%, 93% and 65%.  All above the 60% I set, but below the 100% pre-translation setting.  Since the option says this:

    "Apply MT when no match is found", so it only applies the MT where there is actually no value in the TM at all.  Since the default value in here is 100% failing to change this value too would be easy to miss.  So if I actually wanted to see MT results for all of these I need to tell Studio it's pre-translating to the same value as the Search, so I should raise my minimum match value to 100% in the Search as well.  When I do that the result is this:

    If I prefer to see results from my TM for all matches above 60% then I should lower the minimum match value to 60% in the Pre-translate as well.  Then I see this:

    I hope that makes sense to you and even more so I hope this resolves the problem you were having?

Children
No Data