DeepL plug in 2017

Hi, I have an SDL 2017 freelance licence, and a DeepL pro subscription. I've downloaded the DeepL plug in from the SDL Appstore, but when I tried to install, my 2017 version SDL was greyed out, with the explanation this means the plug in is not compatible with this version. I double checked, downloaded again, and it's definitely the plug in for version 2017. Just to be sure I downloaded the 2019 plug in as well, and my version was greyed out in the installer (as expected). Any advice appreciated. thanks, Brendan,