Thousands separators

I have an irritating problem. In the source the numbers are 50,801 which translated automatically to 50801, but I want a separator, 50 801. I set the space, but then Studio takes it bak to 50801 again. Where are the settings for that. Have looked at others with the same problem where you are supposed to start a new TM, but there must be an easier way to get around the problem.