Error message sdl.languagecloud.identityApi: older version of the installed API.

I have just migrated from Studio 2017 to 2019. When opening the program I get this error message: sdl.languagecloud.identityApi: older version of the installed API

I can pretranslate documents, but when I want to confirm a segment, the following error message appears: Can't load the type sdl.core.settings.abstractsettingsgroupbase" from "sdl.core.settings, version=1.8.0.0, culture=neutral, publickeytoken=c28cdb26c445c888".

I have windows 7.

Please, help me, I am on tight a deadline!

Top Replies