Error message sdl.languagecloud.identityApi: older version of the installed API.

I have just migrated from Studio 2017 to 2019. When opening the program I get this error message: sdl.languagecloud.identityApi: older version of the installed API

I can pretranslate documents, but when I want to confirm a segment, the following error message appears: Can't load the type sdl.core.settings.abstractsettingsgroupbase" from "sdl.core.settings, version=1.8.0.0, culture=neutral, publickeytoken=c28cdb26c445c888".

I have windows 7.

Please, help me, I am on tight a deadline!

Top Replies

Parents
  • Hello

    The error seems to suggest that you are not on the latest version.

    Please update your Studio version to the latest release-

    Then close Studio and restart.

    You may need to recreate the project.

    Did this fix the issue?

  • Hi Steven,

    I have just reinstalled Studio 2017 and when trying to confirm segments the same error above pops up. I am trying to copy-paste a screenshot of it, but don't manage to. It's this one anyway:

    Can't load the type sdl.core.settings.abstractsettingsgroupbase" from "sdl.core.settings, version=1.8.0.0, culture=neutral, publickeytoken=c28cdb26c445c888

    I have checked for updates as you suggested in reply to Romina. When trying to install them, another error appears, reading:

    Could not open key: UNKNOWN\Components\156674BA88667B65BAC2741892EADCE2\EB0BFC7DB30BA5F448B6273CAC3D55FB. Verify that you have sufficient access to that key or contact your support personnel

    When clicking on OK, a third error window shows:

    Setup did not complete. The error is: Package "SDL WorldServer Components" could not be installed. Fatal error during installation. Error number: 1603

    Any suggestions about how to solve this issue?

    Thank you in advance for your help.

  • Please post into a new thread and not on the back of this one.  Then it's easy for us to engage support to assist you with this problem.

Reply Children
No Data