Localisation/number substitution settings

Hello,

I would like some help with number substitution/localisation settings in Studio 2017. I *think* that since I switched from Studio 2015 to 2017, I have lost/changed a setting somewhere which means that substitution/localisation is no longer working correctly.

Here are some screenshots to illustrate my problem (source language FR, target language EN):

I start with this:

When I confirm the first segment (having changed the French comma to a decimal point for English), I get this:

All of the following three segments are propagated as 100% and confirmed, but all are incorrect :-/

I therefore edit segment 2 manually:

And confirm it:

But segments 3 and 4 are still incorrect :-/

In another example, from a German > English translation, I translated the German segment "40.000 €" as "€40,000". Studio then filled in a later segment "30.000€" as "€30 000" in English: it correctly moved the € sign to the beginning, but inserted a space instead of the comma.

Is this behaviour normal? Or should Studio be able to handle cases like this? If so, I imagine there must be something wrong in my settings, but I can't work out where/what to change.

Thanks,

Hayley

  • Dear Hayley,

    Have you checked in Auto-Substitutions if all tokens have been enabled?

    You can do this in Options or Project Settings, then Language Pairs, then the specific Language Pair you want to use, then Translation Memory and Automated Translation, then finally Auto-Substitution.

    Kind regards,

    Guillaume

  • Hello,

    This is what my Auto-substitution settings look like, so yes:

    Hayley

  • Hi Hayley,

    Yes these settings are correct, Auto-substitution should work.

    I am sorry my solution did not work, however the SDL Community is the right place for such queries. I am sure one of our experts can suggest another resolution (maybe @Paul Filkin).

    Kind regards,

    Guillaume
  • Hi Hayley,

    What struck me from your screenshots is that the numbers are not recognised at all. You can see this because there is no blue line underneath them. Are you using a TM and do you have number recognition enabled? The lack of recognition is almost certainly the reason for this problem.

    Regards

    Paul
  • In fact , if you have time we could take a quick look over Skype? This may be faster to get to the bottom of the problem. Drop me an email at pfilkin@sdl.com if this is ok and we can do this now.

    Regards

    Paul
  • Hi Paul,

    I didn't realise it was necessary to be using a TM for the auto-substitution/localisation to work (?) but in any case, even when  I re-did the example above with a FR-EN TM, I got the same results:

    You can see that the blue underlines are there this time, so number recognition must be working correctly (?)

    I'm afraid I don't have Skype.

    Hayley

  • Hello Hayley,

    In all your screenshots the segments are not autopropagated, they are matches coming direct from your TM.  Can you check that you don't have these incorrect entries already in your TM and if you do can you delete them from your TM?

    The best way to see if they should be handled correctly  is to enter a segment and then press Ctrl+comma.  This will trigger a small dropdown box with the suggested localization of the number.  Hopefully the correct one.

    Alternatively, remove your TM, create a new one, and test again with an empty TM.  This at least would demonstrate that this is your TM at work.

    When I try this I get this:

    Which looks ok I think?

    Regards

    Paul

  • Hi again Paul,

    Your results do indeed look ok (and at least confirm to me that I'm not expecting the impossible!), but I can't replicate them.

    I opened my test file again, but with a brand new, empty TM. This is what happens:

    Segment 1 gets automatically translated (how?? I have no automatic translation providers enabled!)

    I confirm segment 1 and get this:

     

    Also, when I now look at the TM, it contains segments 2+3+4. This raises two questions for me:

    • Why is segment 1 (that I confirmed) not been sent to the memory?
    • Why have segments 2+3+4 (that Studio automatically confirmed and marked as 100%) been sent to the memory?

    Thanks in advance - I appreciate all your help in understanding the ins and outs of Studio!

    Hayley

  • I realised it might help to show my settings:

      

    I unchecked the two checkboxes relating to Automatic Translation and re-did my test file (after emptying the TM). Still no luck though (other than that I no longer have the 'AT' result for the first segment):

    Hayley

  • Hello Hayley,

    I don't know if you have managed to find a solution for your problem. I use 2017 too and had the same problem.
    I read Paul filkin's comment about number recognition and went to check my settings. I turned on alphanumerical recognition in the TM's fields and Settings and, lo and behold, the numbers are now being recognized and the replacement option works with the proper number separators.
    (you can find it in Language Pairs/All Language Pairs/Translation Memory and Automated Translation, then go to the Settings tab in the window to the right and enable Alphanumerical Strings in the Fields and Setting menu)

    This helped me, hope it can contribute to someone with the same problem.
  • Hi all,
    I am having the same problem - numbers are propagated in their original format and not in the format of the target language. I have been translating with Studio 2017 from Italian to English since the programme came out and have not encountered any problems of this nature, but am currently working from French for the first time and numbers are automatically translated in the original (French) format. Any help would be appreciated!
    Lynne
  • Hi ,

    Perhaps you can share a screenshot of what you are seeing, or even better create a small sample file that demonstrates the problem? In the meantime this article might also be useful:

    multifarious.filkin.com/.../