Please note: On Sunday 16th May 00AM – 04AM CEST we will be performing planned maintenance on the RWS Community website. During this time you will not be able to access the website and post/reply. Apologies for the inconvenience.

Trados 2017 Export / Update for Bilingual Review (problems editing the target column in Word)

Hello, I have opened this topic because finally I realized that I really need this method Export / Update for / from Bilingual Review to achieve what I need, and that is introducing a lot of text at once in the target column inside Trados.

I want to use this method Export / Update for / from Bilingual Review because it preserves the format, links, special characters, etc., in the original source column.

The problem is this:

I have a document called SAMPLE1.docx, it is in english, an article from a magazine.

Now, I want to introduce a pre-translation (for example), so I use any online source or any software.

Now I have the pre-translation in a TXT file, I open it with the blockpad for example... and I want to copy all the pre-translation I have in the blockpad in the target column inside Trados 2017. The problem is I have to go segment per segment copying and pasting which is completely crazy. I need a method to automate the process.

In word, copying and pasting inside a column is very easy, just take a look to this video: https://youtu.be/4zMfuzoWLv8?t=1m47s

In that video you can see how easy is to copy and paste information inside columns of a table in Word.

What I want to do is the following, please read carefully:

  • Open my word document to Translate in Trados 2017.
  • The document is opened, I have the editor and only the source column is full with the text of the document, the target column is empty because the document was not translated.
  • Now I create an Export for Bilingual Review. Then, Trados creates a folder and inside that folder I have a file called: SAMPLE1.docx_en-US_es-ES.review.docx
  • You can download this file clicking here and then pressing the arrow pointing down: https://drive.google.com/file/d/1Vkl6xA9EZJa3MMPM8K6CWbtoGOi_1PPr/view?usp=sharing
  • Now, if you open the file... you will see it has 4 columns with the following names:

Segment ID

Segment status

Source segment

Target segment

  • Source column contains the source text for the translation and target column contains the translated text.
  • IN THE WORD FILE CREATED FOR BILINGUAL REVIEW... WHAT I WANT IS TO COPY ALL THE TEXT IN MY BLOCKPAD TO THE TARGET SEGMENT COLUMN.
  • Then I want to use the Bilingual Review file to Update Trados 2017 with it, and now yes I should have the Source column with its text for translation, and the Target column with the text I copied from the blockpad and pasted it into this column inside Word.
  • PROBLEM: When I do this and I save my file in Word, later, when I go to Trados and I try to use Update from bilingual review, nothing happens, that is... I cannot see in the Target segment column the text I have introduced in its rows inside Word. What I need is that the text I have introduced inside word, in the column Target Segment be shown inside the Trados editor.

Basically the problem is that when I add text to the rows of the column named Target Segment in the file created by Trados for bilingual review, that text I introduce manually in word, it is not shown later on inside Trados in the editor, when I use the word file to Update the bilingual review.

I would need please, a solution for this, please.

  • Hi Jesus

    after having carefully read your post, I noticed that, probably, you have not correctly understood what a bilingual review MS word document is.

    In fact, when exporting a bilingual review MS Word document, it is supposed that target column should contain some text which, when modified and since the export bilingual review MS Word file has the “Track changes” activated by default, report pertinent “track changes” formatted text (say, strikethrough or different colours, according to your personal settings).

    Before exporting your SDL file to an External Review MS Word file, try to copy all source segments to the pertinent target Studio Editor column selecting all segments and running the command “Copy source to Target” (or CTRL+INS) to populate target column segments and you will get identical content for source and target columns and save the project.

    Now export your Studio file to MS Word review document, open it, and, without deactivating the “Track changes” feature, select the “fake” translated text, copy your external “real” translated text and paste it in the proper row to replace the “fake” target text. The old “fake” target text will assume the formatting of a deleted text while the pasted one the formatting of inserted/changed text. Repeat this process until the last segment, and save the file, without deactivating “Track changes”.

    When you subsequently import the reviewed MS Word file in your Studio Editor view, the target column will be populated with your deleted and newly inserted text (formatted in a way similar to the MS Word file).

    At this point, run the command “Review > Accept > Accept all changes in Document” to clean up the target translated column and save the project.

    But pay attention to possible tags (if present).

    Game over.

    I do not think that this procedure will work if you start it with empty target column.

    I hope this may help.

    Claudio

  • Claudio, please, read this well.

    YOU ARE A GENIOUS ! You have found the solution !

    Yes, that is what I really needed and you found the solution. These days I am very busy, but I promise you I will create a video showing step by step how to do what you said. I will try to post the video here, so people can find an easy way to do this process without having to read all the explanations given.

    The solution worked fantastic. You found a way to trick the system and you deserve an ovation, an applause and all my respect and consideration.

    Great job. Well done.

  • What I don't quite understand is why don't you pre-translate directly in Studio... why do you put your translations somewhere into an external TXT file (and then have to do some crazy harakiri to transfer the pre-translations to Studio)...
  • Hi Jesus,

    happy that you found my suggestion useful and working.

    I’m not a genius, but just a common user trying to manage texts, graphics and to make the most of IT resources, machines, software and applications.

    Computers, software, hardware and other IT resources are nothing “magical”, instead they are “logical” resources. It’s up to us understanding, exploit and apply this logic.

    The basic principle when dealing with IT resources is to understand and to recognize that they are not, and won’t be, “intelligent” (compared to human brain) but just “logical” (“Yes-No”, “0-1”, “True-False”…. i.e., no "grey zones" between them), therefore they work following instructions, programming code and features guiding their behaviour. When you run away from their logic (no matter if simple or complex) you won’t be able to obtain the outcome you are expecting to get.

    Claudio

  • Hi back!

    As I promised, here is the videotutorial. In the meantime, the videotutorial is bilingual (English / Spanish) but the audio is in Spanish. I want to create a different version with the audio in English, anyway, for the moment this video is enough because you have the english subtitles along with the Spanish subtitles.

    I hope you like it, and it may help many people having the same problem.

    How to "inject" a pre-translation inside Trados

    To watch this video in Youtube (full screen) just hover the mouse pointer over it, and when you see the Youtube logo, click on it.

    Cheers

  • Still, it looks like you are "solving" something (using this crazy process) you should not be getting into at all in the first place... because you should pre-translate directly in Trados Studio, NOT somewhere outside into a TXT file.
  • There are no harakiri processes, there are no monsters in the wardrobe and there are no crazy processes. Pejorative adjectives don't change the result of the process. It works. It allows to inject a pre-translation directly into the target column. End of the story.

    To pre-translate directly in Studio you have to PAY, which is not suitable for all users (specially freelance translators working ocasionally in the sector).

    If you can upload a video with the same quality, explaining step by step how to pre-translate inside Trados without having to pay anything I will be waiting for it.
  • It of course depends on HOW do you pretranslate... which service/TM do you use. Untill you tell us some more details, there is hardly a way to effectively help you.
  • JESUS SANCHEZ said:
    If you can upload a video with the same quality, explaining step by step how to pre-translate inside Trados without having to pay anything I will be waiting for it.

    Hi  

    Perhaps another way to do this if you are trying to avoid paying for Machine Translation (which is what you must be referring to since pre-translation in Trados itself is free) is this:

    1. Export to Excel (no need to copy source to target first) using one of several apps available for this and you can also do all your files in one go and insert into a single Excel file for the translation process if you like
    2. Copy the source column into the webpage of your preferred MT engine
    3. Get the translation and copy it into the target column of your excel file
    4. Use the Glossary Converter to convert the Excel to a TMX
    5. Upgrade the TMX in Studio and pretranslate your project

    This may be more reliable as the process you are using is not designed to be used like this, it is for light editing.  It can work, and you have demonstrated this, but it's a bit unreliable for heavy editing.

    Incidentally, you can copy all the source to target in your video using a keyboard shortcut, the default is Alt+Shift+Insert.

  • Hi

    Pre-translation in Trados itself is free? Really?

    I would like, please, to see a video in which you show how to use the pre-translation for free inside Trados.

    I guess you need to be registered in a SDL website?

    A whole video showing the registration process and the way to configure Trados for pre-translation would be nice.

    I tried also the bilingual excel, but I am sorry, I prefer the method I have described because that way I maintain the format in the source column, if I carry data to Excel I start to lose format

    Cheers

  • Hi ,

    Of course it's free... it's been an out of the box feature of Studio for the Freelance and Professional versions of the product since Studio 2009 and is even part of the process when you create a project. Interestingly enough I ran the pre-tranlsate feature as a separate batch task in an article I wrote over the weekend:

    multifarious.filkin.com/.../

    The pretranslate is in the first video related to projectAnonymizer and starts at around 6 minutes in.

    Are you sure you are not referring to pre-translate with Machine Translation? I really can't think of any reason for your workaround unless you are trying to avoid paying for Machine Translation with an MT provider that requires a paid for API key. If you use SDL Language Cloud then for a Freelance translator even that is probably free as I think most translators are unlikely to hit the limit of the free MT unless they do a lot of project preparation work... even MyMemory has a free option.

    Glad you found a process that's working for you anyway. If you're happy, I'm happy!
  • JESUS SANCHEZ said:
    A whole video showing the registration process and the way to configure Trados for pre-translation would be nice.

    Registration WHERE?
    You still did not answer the simple question - HOW exactly do you "pre-translate", which service exactly do you use?

    You really seem to be missing something about how the Studio process works, what exactly is pre-translation (and what is the difference between translation memory, auto-translation, machine translation providers, etc.), etc., which makes you believe something what is not entirely true.

    If you like to do way more work than you actually need to do (just because you believe that your way is the only one), it's fine... it's your (wasted) time.
    But you should not confuse other potential readers of the forum by your incorrect conclusions and statements, based on presumably incorrect assumptions.

  • Evzen Polenka, the question was for Paul, not for you. Due you are showing since the last posts an "aggresive attitude" I kindly ask you that do not participate in this post anymore.  I kindly invite you to leave the post, and do not post anymore in this thread I opened. If finally you decide not to leave the post be warned that in order to avoid confrontations I will ignore your messages. Thanks for your understanding and cooperation.

  • Hi ,

    I don't think means to come across as aggressive. I think it is just a case of being from different countries, where someone from one culture uses a 'tone of voice' that is perceived differently to its real intention, by someone from another culture because if they used that 'tone of voice' it would mean something different in their own culture.

    ...or something like that!

    All the best,

    Ali [:D]

    [{][}]

  • The solution is working fantastic, is all I can say.

    Cheers

    [Y]