Auto Save

Hi,

I periodically encounter the very annoying phenomenon that the Auto Save pop-up window is taking the screen focus as I'm typing, and some letters or even words are lost if the operation takes longer (large file). I think, Auto Save should take place silently in the background, just like in other apps (eg. MS Office). 

Then the cursor returns to the target sergment where I was, so I don't have the problem mentioned by someone before (cursor placed elsewhere).

Thanks for any ideas (or fixing this in an upcoming update).

  • Hi

    Can you tell me if you save your files in dropbox, one drove or something like that? Or maybe on an external drive?
  • Dear Paul,

    Thank you for your question. No, I am just normally saving on the local HDD.
  • Hi

    What spec is your computer? Hardware and operating system? Also which version of Studio are you using?
  • I am using Studio 2019. Under Windows 10 (64 bit) with a Core i3, 8GB RAM and SSD for system/programs, HDD for data. So it should not be this slow. Generally, it is fast enough, sometimes Sudio is a bit clumsy when opening, saving big files.

    But the only issue is with this Auto Save dialog window popping up. I think it should save in the background.

  • I am now also getting the same: a pop-up window that takes the focus for a couple of seconds. I recently played with the settings to set AutoSave to 5 minutes. Prior to that, I don’t exactly remember whether AutoSave was on or off. However, I kind of remember seeing a blue bar regularly running in the status bar, which might have been AutoSave. Furthermore, I have recovered “more recent versions automatically recovered” after crashes, so I would imagine that some kind of autosaving option was running.

    This pop-up window is annoying enough for me to consider not using AutoSave. As Tamás mentioned, you’d expect that to run in the background…

    I’m using 2019 SR2 on a pretty fast computer (no hardware changes prior to the pop-up windows) running the latest Win10. I am indeed saving to Dropbox (nothing new there either), but still, locally on a M.2 drive.

  • It just dawned on me that it might be related to the size of the project… The SDLXLIFF I’m working on is a bit over 5MB and has about 2,500 segments. Still, why the pop-up?

  • Yes. The slow auto-save problem is related to the size of the file. But still... Now I am using a Core i7/16GB system woth 2 fast SSDs (no DropBox save) and the problem is the same. DropBox should not make any problem as it is a local drive folder on this side.

    Another, more annoying bug is related to large TMs I think. Sometime, the whole program freezes and crashes on segment chane, without any warning. Then after launching it again, everything goes well. It happens at least once a day in average... 

    I think, we would need fixes for a reliable SW instead of new fancy functions in the updates...

  • Yes this issue is really annoying I have to admit. I am surprised it is still happening 2 years after it was flagged. Please fix this guys.

  • I know this is an old question, but I am also experiencing this problem. I am translating a very large file with 12K segments, using Studio 19 SR2, Win 10 (64 bit), Intel code i5 2.5 GHz, 8G Ram. The Auto-save dialog runs for a number of seconds, long enough to make me wait, while it is taking away focus and hiding the segment I was working in. Each time, there is a small amount of mental and typing recovery afterwards. As other colleagues mentioned, the save should take place in the background, and there should be no need for the dialog. There is already a progress bar in the status bar, although it is not essential, but it doesn't do any harm. The pop-up does.

  • The question might be old but the problem is the same. Meanwhile, I have upgraded to Studio 2020. And still the same. Both the crappy auto-save and sometimes the crashes. Come on, SDL! Instead of new fancy features, fix the bugs! This is not an entertainment game but a tool for work many people pay a lot for!