Pre-translate freezing, taking forever to cancel, taking a long time to save, stalling on "searching" TM hits, eating CPU

Hello,

Lately pre-translate has been taking forever. Sometimes over an hour for processes that used to take just a few minutes. If it's not slow, then it simply freezes. 

This small project using a local TM and MT (I remove the MT it's still slow with the local TMs) decided to freeze at 68%. It stayed there for 20 minutes and then I gave up and canceled. Then instead of immediately canceling, it just said "canceling" for 10 or 15 minutes. 

During this time, I tried just forcing trados to close down. This what my task manager looked like. 

I tried individually closing down the batch processing window and SDL Trados window but it didn't close. Instead, I got another error telling me to first close the batch processing window with the "cancel" button. But as you can see above, all buttons were greyed out on the patch processing window. 

After about 10 minutes I was able to close it all down but this was so frustrating not even being able to forcibly close down Trados.

Why is this happening?

I use the latest version of Studio 2017. And have a fairly beefy, new computer that was bought to specifically to handle Trados.

So, then I just went to translate normally without doing a pre-translate and Trados wouldn't return TM or MT hits. It would just say "searching" and never finish.

Simply saving the xliff takes a minute. After clicking Batch Task, it takes a minute for the drop down screen to return.

While it was "saving" my CPU usage of Trados peaked around 93%. 

 

I referred to this similar sounding post:  https://community.sdl.com/product-groups/translationproductivity/f/90/t/13504#pi6614=1

I tried turning of fragment matching for both editor and batch tasks. Didn't work. Froze at 69% and is still currently "canceling".

This time it's a 4-page word document in Japanese, similar to the linked post. On Monday I'll try copying the text to a txt file and see if that works.

Any other suggestions though?